aboutsummaryrefslogtreecommitdiffstats
path: root/indonesian/Makefile
diff options
context:
space:
mode:
authorMartin Schulze <joey>2001-09-27 10:19:46 +0000
committerMartin Schulze <joey>2001-09-27 10:19:46 +0000
commit9dd717af280ff16888fdbe016d6a9773fa66eaf3 (patch)
tree01799f2fbb4ea409861876fab1db38f61c0ae210 /indonesian/Makefile
parent78026c20c5c4d3b5910b553a2da670b1ae74985d (diff)
Committed files for Junaedi Kartawijaya
CVS version numbers indonesian/.wmlrc: INITIAL -> 1.1 indonesian/Make.lang: INITIAL -> 1.1 indonesian/Makefile: INITIAL -> 1.1 indonesian/contact.wml: INITIAL -> 1.1 indonesian/donations.wml: INITIAL -> 1.1 indonesian/index.wml: INITIAL -> 1.1 indonesian/license.wml: INITIAL -> 1.1 indonesian/search.wml: INITIAL -> 1.1 indonesian/social_contract.wml: INITIAL -> 1.1 indonesian/support.wml: INITIAL -> 1.1 indonesian/Pics/Makefile: INITIAL -> 1.1 indonesian/Pics/pics.conf: INITIAL -> 1.1
Diffstat (limited to 'indonesian/Makefile')
-rw-r--r--indonesian/Makefile69
1 files changed, 69 insertions, 0 deletions
diff --git a/indonesian/Makefile b/indonesian/Makefile
new file mode 100644
index 00000000000..76c3b19b0d4
--- /dev/null
+++ b/indonesian/Makefile
@@ -0,0 +1,69 @@
+# This Makefile should need no changes from webwml/english/Makefile
+# Please send a message to debian-www if you need to modify anything
+# so the problem can be fixed.
+
+WMLBASE=.
+CUR_DIR=
+SUBS=Bugs MailingLists News Pics banners chinese consultants devel distrib \
+doc events intro international logos mirror misc partners ports releases \
+searchtmpl security vote y2k
+
+ifneq "$(wildcard om_svenska/Makefile)" ""
+SUBS += om_svenska
+endif
+
+include $(WMLBASE)/Make.lang
+
+ifndef SUBLANG
+SITEMAP = sitemap.$(LANGUAGE).html
+HTMLMAP = $(HTMLDIR)/$(SITEMAP)
+else
+SITEMAP = $(sort $(foreach i,$(SUBLANG),\
+ $(patsubst %.wml,%.$(LANGUAGE)-$(i).html,sitemap.wml)))
+HTMLMAP = $(patsubst %.html,$(HTMLDIR)/%.html,$(SITEMAP))
+endif
+
+index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/mainpage.wml \
+ $(wildcard News/$(CUR_YEAR)/[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/News/$(CUR_YEAR)/[0-9]*.wml) \
+ $(wildcard security/$(CUR_YEAR)/dsa-[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-[0-9]*.wml) \
+ $(TEMPLDIR)/ctime.wml $(TEMPLDIR)/recent_list.wml $(TEMPLDIR)/languages.wml \
+ $(ENGLISHSRCDIR)/releases/info
+ $(WML) index.wml
+
+$(SITEMAP): $(ENGLISHDIR)/sitemap.wml \
+ $(TEMPLDIR)/links.tags.wml $(TEMPLDIR)/template.wml \
+ $(ENGLISHDIR)/releases/info $(ENGLISHDIR)/MailingLists/mklist.tags
+ifeq "$(LANGUAGE)" "zh"
+ $(shell echo $(WML) | sed s/:.zh/:sitemap.zh/g) \
+ $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml \
+ $(shell egrep '^-D (CUR_|CHAR)' .wmlrc)
+ @echo -n " * Converting: [zh_CN.GB2312], "
+ @$(B5TOGB) < sitemap.zh-cn.html.tmp > sitemap.zh-cn.html
+ @rm -f sitemap.zh-cn.html.tmp
+ @$(TOCN) sitemap.zh-cn.html
+ @echo -n "[zh_HK.Big5], "
+ @mv -f sitemap.zh-hk.html.tmp sitemap.zh-hk.html
+ @$(TOHK) sitemap.zh-hk.html
+ @echo "[zh_TW.Big5]."
+ @mv -f sitemap.zh-tw.html.tmp sitemap.zh-tw.html
+ @$(TOTW) sitemap.zh-tw.html
+else
+ifeq "$(LANGUAGE)" "ja"
+ wml -q -D CUR_YEAR=2001 -o UNDEFuJA:sitemap.ja.html.tmp@g+w \
+ --prolog="/usr/bin/kcc -e -" --epilog="./convert sitemap.ja.html" \
+ ../english/sitemap.wml \
+ -D CUR_LANG=Japanese -D CUR_ISO_LANG=ja -D CHARSET=iso-2022-jp
+else
+ $(shell echo $(WML) | sed s/index/sitemap/) \
+ $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml \
+ $(shell egrep '^-D (CUR_|CHAR)' .wmlrc)
+endif
+endif
+
+all:: $(SITEMAP)
+
+install:: $(HTMLMAP)
+ifeq "$(LANGUAGE)" "en"
+ test -f $(HTMLDIR)/favicon.ico || install -m 664 favicon.ico $(HTMLDIR)
+endif
+ test -L $(HTMLDIR)/intl || ln -sf international $(HTMLDIR)/intl

© 2014-2024 Faster IT GmbH | imprint | privacy policy