aboutsummaryrefslogtreecommitdiffstats
path: root/french/Makefile
diff options
context:
space:
mode:
authorChristophe Le Bars <clebars>1998-09-02 03:34:02 +0000
committerChristophe Le Bars <clebars>1998-09-02 03:34:02 +0000
commit420d42d875f2c537d963090c45f1d59de837e505 (patch)
treec7db0bcd5a84cab8356171a0546318cade846a94 /french/Makefile
parent67a970d74c4b480bda71adc5bbe94bd603e27c90 (diff)
Nouveaux Makefile
CVS version numbers french/.wmlrc: 1.1 -> 1.2 french/Make.lang: INITIAL -> 1.1 french/Make.templ.inc: INITIAL -> 1.1 french/Makefile: 1.5 -> 1.6
Diffstat (limited to 'french/Makefile')
-rw-r--r--french/Makefile125
1 files changed, 28 insertions, 97 deletions
diff --git a/french/Makefile b/french/Makefile
index d4d16abed79..8e7fef4161d 100644
--- a/french/Makefile
+++ b/french/Makefile
@@ -1,100 +1,31 @@
-LANG=fr
-HTMLDIR=../../debian.org
-TEMPLDIR=template/debian
-ENGLISHSRCDIR=../english
-# EPILOG=--epilog=weblint
-$(HTMLDIR)/%.html.$(LANG) : %.wml $(TEMPLDIR)/template.wml
- cd $(<D) && wml $(EPILOG) $(<F)
-# cd $(<D) && wml -o $@ $(EPILOG) $(<F)
-
-# translators should comment out the line for any file they haven't translated.
-all:\
- $(HTMLDIR)/contact.html.$(LANG) \
- $(HTMLDIR)/donations.html.$(LANG) \
- $(HTMLDIR)/index.html.$(LANG) \
- $(HTMLDIR)/license.html.$(LANG) \
- $(HTMLDIR)/social_contract.html.$(LANG) \
- #$(HTMLDIR)/developers_corner.html.$(LANG) \
- #$(HTMLDIR)/news.html.$(LANG) \
- #$(HTMLDIR)/news1997.html.$(LANG) \
- #$(HTMLDIR)/related_links.html.$(LANG) \
- #$(HTMLDIR)/sponsor.html \
- #$(HTMLDIR)/support.html.$(LANG) \
- #$(HTMLDIR)/2.0/errata.html.$(LANG) \
- #$(HTMLDIR)/2.0/2.0beta_CD.html.$(LANG) \
- #$(HTMLDIR)/2.0/HOWTO.upgrade.html.$(LANG) \
- #$(HTMLDIR)/MailingLists/debian-announce.html.$(LANG) \
- #$(HTMLDIR)/MailingLists/subscribe.html.$(LANG) \
- #$(HTMLDIR)/MailingLists/unsubscribe.html.$(LANG) \
- #$(HTMLDIR)/devel/HOWTO_translate.html.$(LANG) \
- #$(HTMLDIR)/devel/extract_key.html.$(LANG) \
- #$(HTMLDIR)/devel/help.html.$(LANG) \
- #$(HTMLDIR)/devel/incoming_mirrors.html.$(LANG) \
- #$(HTMLDIR)/devel/maintainer_contacts.html.$(LANG) \
- #$(HTMLDIR)/devel/mirror.html.$(LANG) \
- #$(HTMLDIR)/devel/mirror_submit.html.$(LANG) \
- #$(HTMLDIR)/devel/people.html.$(LANG) \
- #$(HTMLDIR)/devel/ports.html.$(LANG) \
- #$(HTMLDIR)/devel/release_info.html.$(LANG) \
- #$(HTMLDIR)/devel/rsync_examples.html.$(LANG) \
- #$(HTMLDIR)/doc/index.html.$(LANG) \
- #$(HTMLDIR)/distrib/distrib.html.$(LANG) \
- #$(HTMLDIR)/distrib/ftplist.html.$(LANG) \
- #$(HTMLDIR)/distrib/packages.html.$(LANG) \
- #$(HTMLDIR)/distrib/vendors.html.$(LANG) \
- #$(HTMLDIR)/intro/about.html.$(LANG) \
- #$(HTMLDIR)/intro/cooperation.html.$(LANG) \
- #$(HTMLDIR)/intro/license_disc.html.$(LANG) \
- #$(HTMLDIR)/intro/cn.html.$(LANG) \
- #$(HTMLDIR)/intro/free.html.$(LANG) \
- #$(HTMLDIR)/intro/why_debian.html.$(LANG) \
- #$(HTMLDIR)/logos/index.html.$(LANG) \
- #$(HTMLDIR)/security/index.html.$(LANG) \
- #$(HTMLDIR)/ports/index.html.$(LANG) \
- #$(HTMLDIR)/ports/sparc/index.html.$(LANG) \
- #$(HTMLDIR)/ports/sparc/problems.html.$(LANG) \
- #$(HTMLDIR)/
-
-
-#
-# TRANSLATORS SHOULD NOT HAVE TO TOUCH ANYTHING BELOW THIS LINE
-#
-
-$(HTMLDIR)/index.html.$(LANG): index.wml ${ENGLISHSRCDIR}/news.wml $(TEMPLDIR)/mainpage.wml $(TEMPLDIR)/ctime.wml
- wml index.wml
-
-# with no rule, the default ruleset (at the top) is used
-$(HTMLDIR)/devel/people.html.$(LANG): devel/people.wml $(ENGLISHSRCDIR)/devel/people.names
-
-
-# template dependencies
+BASE=.
+HTMLDIR=$(BASE)/../../debian.org
+TEMPLDIR=$(BASE)/template/debian
+ENGLISHSRCDIR=$(BASE)/../english
-template/debian/basic.wml: template/debian/navbar.wml
- touch template/debian/basic.wml
+include $(BASE)/Make.lang
-template/debian/footer.wml: template/debian/ctime.wml
- touch template/debian/footer.wml
+WMLFILES := $(wildcard *.wml)
+HTMLFILES := $(patsubst %.wml,$(HTMLDIR)/%.html.$(LANGUAGE),$(WMLFILES))
-# template/debian/languages.wml: template/debian/
-# touch template/debian/languages.wml
-
-template/debian/menubar.wml: template/debian/footer.wml
- touch template/debian/menubar.wml
-
-# template/debian/recent_news.wml: template/debian/
-# touch template/debian/recent_news.wml
-
-# template/debian/ctime.wml: template/debian/
-# touch template/debian/ctime.wml
-
-template/debian/mainpage.wml: template/debian/basic.wml template/debian/menubar.wml
- touch template/debian/mainpage.wml
-
-# template/debian/navbar.wml: template/debian/
-# touch template/debian/navbar.wml
-
-template/debian/template.wml: template/debian/basic.wml template/debian/footer.wml
- touch template/debian/template.wml
-
-people: devel/people.wml
- cd devel && wml people.wml
+# EPILOG=--epilog=weblint
+$(HTMLDIR)/%.html.$(LANGUAGE) : %.wml $(TEMPLDIR)/template.wml
+ wml -q $(EPILOG) $(<F)
+
+all: $(HTMLFILES)
+ ( cd 2.0; $(MAKE) )
+ ( cd MailingLists; $(MAKE) )
+ ( cd News; $(MAKE) )
+ ( cd SPI; $(MAKE) )
+ ( cd devel; $(MAKE) )
+ ( cd distrib; $(MAKE) )
+ ( cd doc; $(MAKE) )
+ ( cd intro; $(MAKE) )
+ ( cd logos; $(MAKE) )
+ ( cd ports; $(MAKE) )
+ ( cd security; $(MAKE) )
+
+include $(BASE)/Make.templ.inc
+
+$(HTMLDIR)/index.html.$(LANGUAGE): index.wml news.wml $(TEMPLDIR)/mainpage.wml $(TEMPLDIR)/ctime.wml $(TEMPLDIR)/recent_news.wml
+ wml -q index.wml

© 2014-2024 Faster IT GmbH | imprint | privacy policy