aboutsummaryrefslogtreecommitdiffstats
path: root/copypage.pl
diff options
context:
space:
mode:
authorRhonda D'Vine <alfie>2002-10-30 15:13:38 +0000
committerRhonda D'Vine <alfie>2002-10-30 15:13:38 +0000
commit0ec70fe48733a796f036e3eb6b016372407d3b05 (patch)
tree26c3eb953d4f3b946bf357f81355e8838cd50584 /copypage.pl
parent58a350e7f8e18185145b35c7d841f5107f1d122c (diff)
Removed copy handling -- sync only support from now on.
CVS version numbers copypage.pl: 1.19 -> 1.20
Diffstat (limited to 'copypage.pl')
-rwxr-xr-xcopypage.pl28
1 files changed, 8 insertions, 20 deletions
diff --git a/copypage.pl b/copypage.pl
index ba7d4f6740e..d2e92db3b45 100755
--- a/copypage.pl
+++ b/copypage.pl
@@ -2,10 +2,9 @@
# This script copies the file named on the command line to the translation
# named in language.conf, and adds the translation-check header to it.
-# It also will create the destination directory if necessary, and copy the
-# Makefile from the source. If the second line of the language.conf file
-# contains the word "sync", a simple Makefile which just includes the English
-# version will be created instead.
+# It also will create the destination directory if necessary, and create the
+# Makefile. It will do this by simply including the English version -- copied
+# Makefiles are not supported anymore for they bear too much space for errors.
# Originally written 2000-02-26 by Peter Karlsson <peterk@debian.org>
# © Copyright 2000-2002 Software in the public interest, Inc.
@@ -16,7 +15,6 @@
use File::Path;
# Get configuration
-$copymakefile = 1;
if (exists $ENV{DWWW_LANG})
{
$language = $ENV{DWWW_LANG};
@@ -28,8 +26,6 @@ elsif (open CONF, "<language.conf")
next if /^#/;
chomp;
$language = $_, next unless defined $language;
- $copymakefile = 1 if $_ eq 'copy';
- $copymakefile = 0 if $_ eq 'sync';
}
}
else
@@ -144,19 +140,11 @@ sub copy
or die "Could not create $dstdir: $!\n";
if ( -e $srcmake )
{
- if ($copymakefile)
- {
- print "creating it and copying $srcmake\n";
- system "cp $srcmake $dstmake";
- }
- else
- {
- print "creating it and making a $dstmake\n";
- open MK, "> $dstmake"
- or die "Could not create $dstmake: $!\n";
- print MK "include \$(subst webwml/$language,webwml/english,\$(CURDIR))/Makefile\n";
- close MK;
- }
+ print "creating it and making a $dstmake\n";
+ open MK, "> $dstmake"
+ or die "Could not create $dstmake: $!\n";
+ print MK "include \$(subst webwml/$language,webwml/english,\$(CURDIR))/Makefile\n";
+ close MK;
}
}

© 2014-2024 Faster IT GmbH | imprint | privacy policy