summaryrefslogtreecommitdiffstats
path: root/lib/debian-releases.mk
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2020-06-04 20:02:34 +0000
committerSalvatore Bonaccorso <carnil@debian.org>2020-06-04 20:02:34 +0000
commit12052760d6f12fd9ec6e3c42afe66449011b01cc (patch)
tree7048810cfb8bae504dcad525e825993ccb01bc48 /lib/debian-releases.mk
parent5691f3044f636bfacb4b1ec5960a290d105cef59 (diff)
parent1b9c4741e886afe5f2bf6a4583d977bac225bdad (diff)
Merge branch 'distro-config' into 'master'
Distro config reunification See merge request security-tracker-team/security-tracker!48
Diffstat (limited to 'lib/debian-releases.mk')
-rw-r--r--lib/debian-releases.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/lib/debian-releases.mk b/lib/debian-releases.mk
index c868d6edfd..ecb72a23a6 100644
--- a/lib/debian-releases.mk
+++ b/lib/debian-releases.mk
@@ -1,18 +1,22 @@
# This file defines the variables describing all Debian repositories
# that need to be fetched in the "update-packages" process
+define get_config =
+$(shell jq -r $(1) 'data/config.json')
+endef
+
# backports suites only have Sources.xz and respective Packages.xz
# available.
# Cf. as well https://bugs.debian.org/664866
#BACKPORT_RELEASES := $(OLDSTABLE) $(STABLE)
-SECURITY_RELEASES := $(OLDOLDSTABLE) $(OLDSTABLE) $(STABLE) $(TESTING)
-MAIN_RELEASES := $(SECURITY_RELEASES) sid
+MAIN_RELEASES = $(call get_config, '.distributions | to_entries[] | select(.value.release) | .key')
+SECURITY_RELEASES = $(filter-out sid, $(MAIN_RELEASES))
# Define the variables for the release on the main mirror
define add_main_release =
$(1)_MIRROR = $$(MIRROR)
$(1)_DIST = $(1)
-$(1)_ARCHS ?= amd64 arm64 armel armhf i386 mips64el mipsel ppc64el s390x
+$(1)_ARCHS = $(call get_config, '.distributions.$(1).architectures[]')
$(1)_RELEASE = $(1)
$(1)_SUBRELEASE =
RELEASES += $(1)

© 2014-2024 Faster IT GmbH | imprint | privacy policy