summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorHolger Levsen <holger@debian.org>2015-04-26 17:10:05 +0000
committerHolger Levsen <holger@debian.org>2015-04-26 17:10:05 +0000
commitc727feceffe592373d5b795351e6ad3fe47060e6 (patch)
tree9d443a141a3441fa6024104f3a128ca19abcaf63 /Makefile
parentdcdae422649ba3834bea55beaec586716ba10836 (diff)
add support for oldoldstable and stretch and make jessie the new stable release
git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@33868 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile54
1 files changed, 43 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index 5507f74e29..be0d74dea8 100644
--- a/Makefile
+++ b/Makefile
@@ -10,11 +10,13 @@ squeeze_ARCHS = amd64 armel i386 ia64 mips mipsel powerpc s390 sparc kfreebsd-i3
squeeze_LTS_ARCHS = amd64 i386
wheezy_ARCHS = amd64 armel armhf i386 ia64 mips mipsel powerpc s390 s390x sparc kfreebsd-i386 kfreebsd-amd64
jessie_ARCHS = amd64 arm64 armel armhf i386 mips mipsel powerpc ppc64el s390x
+stretch_ARCHS = amd64 arm64 armel armhf i386 mips mipsel powerpc ppc64el s390x
sid_ARCHS = amd64 arm64 armel armhf hurd-i386 i386 kfreebsd-i386 kfreebsd-amd64 mips mipsel powerpc ppc64el s390x sparc
-OLDSTABLE = squeeze
-STABLE = wheezy
-TESTING = jessie
+OLDOLDSTABLE = squeeze
+OLDSTABLE = wheezy
+STABLE = jessie
+TESTING = stretch
all:
$(PYTHON) bin/update-db data/security.db
@@ -115,7 +117,23 @@ update-oldstable:
done ; \
done
-.PHONY: update-security update-old-security update-testing-security
+update-oldoldstable:
+ set -e ; for rel in $(OLDOLDSTABLE) ; do \
+ for archive in main contrib non-free ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(MIRROR)/dists/$$rel/$$archive/source/Sources \
+ data/packages/$${rel}__$${archive}_Sources ; \
+ done ; \
+ for arch in $($(OLDOLDSTABLE)_ARCHS) ; do \
+ for archive in main contrib non-free ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(MIRROR)/dists/$$rel/$$archive/binary-$$arch/Packages \
+ data/packages/$${rel}__$${archive}_$${arch}_Packages ; \
+ done ; \
+ done ; \
+ done
+
+.PHONY: update-security update-old-security update-oldold-security update-testing-security
ST_MIRROR = http://security.debian.org/dists/$(TESTING)/updates
ST_FILE = data/packages/$(TESTING)_security_
update-testing-security:
@@ -127,7 +145,7 @@ update-testing-security:
done
SEC_MIRROR = http://security.debian.org/dists
-update-security: update-old-security
+update-security: update-old-security update-oldold-security
for archive in $(STABLE); do \
for section in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
@@ -141,7 +159,7 @@ update-security: update-old-security
done ; \
done
-update-old-security: update-lts
+update-old-security:
for archive in $(OLDSTABLE); do \
for section in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
@@ -155,9 +173,23 @@ update-old-security: update-lts
done ; \
done
-update-lts: update-lts-$(OLDSTABLE)
+update-oldold-security: update-lts
+ for archive in $(OLDOLDSTABLE); do \
+ for section in main contrib non-free ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(SEC_MIRROR)/$$archive/updates/$$section/source/Sources \
+ data/packages/$${archive}_security_$${section}_Sources ; \
+ for arch in $($(OLDOLDSTABLE)_ARCHS) ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(SEC_MIRROR)/$$archive/updates/$$section/binary-$$arch/Packages \
+ data/packages/$${archive}_security_$${section}_$${arch}_Packages ; \
+ done ; \
+ done ; \
+ done
+
+update-lts: update-lts-$(OLDOLDSTABLE)
-update-lts-$(OLDSTABLE):
+update-lts-$(OLDOLDSTABLE):
set -e && archive=$(shell echo $@ | cut -d- -f3) ; \
for arch in $($(shell echo $@ | cut -d- -f3)_LTS_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
@@ -169,9 +201,9 @@ update-lts-$(OLDSTABLE):
data/packages/$${archive}-lts__main_Sources ; \
BACKPORTS_MIRROR = http://ftp.de.debian.org/debian-backports/dists
-update-backports: update-backports-$(STABLE) update-backports-$(OLDSTABLE)
+update-backports: update-backports-$(STABLE) update-backports-$(OLDSTABLE) update-backports-$(OLDOLDSTABLE)
-update-backports-$(OLDSTABLE):
+update-backports-$(OLDOLDSTABLE):
set -e && archive=$(shell echo $@ | cut -d- -f3) ; \
for arch in $($(shell echo $@ | cut -d- -f3)_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
@@ -204,4 +236,4 @@ update-nvd:
done
python bin/update-nvd data/nvd/nvdcve-*.xml
-update-all: update-nvd update-lists update-packages update-oldstable update-stable update-security update-testing-security update-packages update-backports all
+update-all: update-nvd update-lists update-packages update-oldstable update-oldoldstable update-stable update-security update-testing-security update-packages update-backports all

© 2014-2024 Faster IT GmbH | imprint | privacy policy