summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFlorian Weimer <fw@deneb.enyo.de>2005-09-13 09:12:19 +0000
committerFlorian Weimer <fw@deneb.enyo.de>2005-09-13 09:12:19 +0000
commita4f546127a2bbbbdfd8f2e5f1b077882b5421673 (patch)
tree0d7bc965a6cf340a87349eac384a5f40b85abee1 /Makefile
parent53c5ed08bcd975c08090343e2cfa338c5bfd6610 (diff)
Add support for downloading Packages and Sources files.
After this change, you must run "make clean update-packages all" to download the package data. lib/python/security_db.py(DB.initSchema): Add table inodeprints. (DB.filePrint, DB._maybeUpdate, DB.maybeUpdateSources, DB.maybeUpdatePackages): Add. (test): Update to new file locations. bin/update-packages: New file. Used by the makefile. data/packages: New directory. Used to store the downloaded files. Makefile: Add "update-packages" and "clean" targets, and the necessary targets to support them. git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@1947 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile34
1 files changed, 33 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a56e60b0b0..276b557df2 100644
--- a/Makefile
+++ b/Makefile
@@ -2,13 +2,38 @@ PYTHON = python
PYTHON_MODULES = $(wildcard lib/python/*.py)
BUG_LISTS = $(wildcard data/*/list)
-all: stamps/bug-lists-imported
+# Adjust these if necessary. The architecture selection is arther
+# arbitrary at the moment. More architectures can be added later.
+
+MIRROR = http://merkel.debian.org/~aba/debian/
+RELEASES_with_proposed_updates = sarge=i386,ia64 etch=i386,ia64
+RELEASES = sid=i386,ia64 $(RELEASES_with_proposed_updates) \
+ $(subst =,-proposed-updates=, $(RELEASES_with_proposed_updates))
+SECURITY_RELEASES = sarge-security=i386,ia64
+PACKAGE_FILES = $(wildcard data/packages/*_Sources) \
+ $(wildcard data/packages/*_Packages)
+
+all: stamps/bug-lists-imported stamps/packages-imported
stamps/bug-lists-imported: bin/update-bug-list-db \
$(BUG_LISTS) $(PYTHON_MODULES)
$(PYTHON) bin/update-bug-list-db
touch $@
+# No dependencies on the Python files. This part of the code should
+# be quite stable. We only run the packages import if "make
+# update-packages" has been invoked before.
+stamps/packages-imported: $(PACKAGE_FILES)
+ if test -e stamps/packages-downloaded ; then \
+ $(PYTHON) bin/update-packages import \
+ $(RELEASES) $(SECURITY_RELEASES) ; \
+ fi
+ touch $@
+
+clean:
+ -rm data/security.db
+ -rm stamps/*-*
+
.PHONY: check check-syntax
test check: check-syntax
@@ -31,3 +56,10 @@ stamps/DSA-syntax: data/DSA/list bin/check-syntax $(PYTHON_MODULES)
stamps/DTSA-syntax: data/DTSA/list bin/check-syntax $(PYTHON_MODULES)
$(PYTHON) bin/check-syntax DTSA data/DTSA/list
touch $@
+
+.PHONY: update-packages
+update-packages:
+ $(PYTHON) bin/update-packages download $(MIRROR) $(RELEASES)
+ $(PYTHON) bin/update-packages download \
+ http://security.debian.org/ $(SECURITY_RELEASES)
+ touch stamps/packages-downloaded

© 2014-2024 Faster IT GmbH | imprint | privacy policy