summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFlorian Weimer <fw@deneb.enyo.de>2010-07-04 16:14:06 +0000
committerFlorian Weimer <fw@deneb.enyo.de>2010-07-04 16:14:06 +0000
commita078a959d55dcd638b767836cc33d94fb8a2bd19 (patch)
tree87af75fbff91838a1dc3aa7cc655d6e527138781 /Makefile
parent544e1424f22b35ca5c70d69a4b022c762e9fd06e (diff)
Makefile: remove oldstable references
oldstable is now archived, so we cannot download it anymore. git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@14959 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile45
1 files changed, 6 insertions, 39 deletions
diff --git a/Makefile b/Makefile
index 54e1effb83..e8d6ffbf42 100644
--- a/Makefile
+++ b/Makefile
@@ -6,16 +6,13 @@ BUG_LISTS = $(wildcard data/*/list)
# arbitrary at the moment. More architectures can be added later.
MIRROR = http://ftp.de.debian.org/debian/
-ETCH_ARCHS = alpha amd64 arm hppa i386 ia64 mips mipsel powerpc s390 sparc
LENNY_ARCHS = alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc
SQUEEZE_ARCHS = amd64 armel hppa i386 ia64 mips mipsel powerpc s390 sparc
SID_ARCHS = alpha amd64 armel hppa i386 ia64 kfreebsd-i386 kfreebsd-amd64 mips mipsel powerpc s390 sparc
-OLDSTABLE = etch
STABLE = lenny
TESTING = squeeze
-OLDSTABLE_uc = $(shell echo "$(OLDSTABLE)" | tr "[:lower:]" "[:upper:]")
STABLE_uc = $(shell echo "$(STABLE)" | tr "[:lower:]" "[:upper:]")
TESTING_uc = $(shell echo "$(TESTING)" | tr "[:lower:]" "[:upper:]")
@@ -52,7 +49,7 @@ stamps/DTSA-syntax: data/DTSA/list bin/check-syntax $(PYTHON_MODULES)
serve:
@bash bin/test-web-server
-.PHONY: update-packages update-testing update-stable update-oldstable
+.PHONY: update-packages update-testing update-stable
update-packages: update-testing
set -e ; for rel in sid experimental ; do \
for archive in main contrib non-free ; do \
@@ -85,7 +82,7 @@ update-testing:
done ; \
done
-update-stable: update-oldstable
+update-stable:
set -e ; for rel in $(STABLE) ; do \
for archive in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
@@ -101,22 +98,6 @@ update-stable: update-oldstable
done ; \
done
-update-oldstable:
- set -e ; for rel in $(OLDSTABLE) ; do \
- for archive in main contrib non-free ; do \
- $(PYTHON) bin/apt-update-file \
- $(MIRROR)/dists/$$rel/$$archive/source/Sources \
- data/packages/$${rel}__$${archive}_Sources ; \
- done ; \
- for arch in $($(OLDSTABLE_uc)_ARCHS) ; do \
- for archive in main contrib non-free ; do \
- $(PYTHON) bin/apt-update-file \
- $(MIRROR)/dists/$$rel/$$archive/binary-$$arch/Packages \
- data/packages/$${rel}__$${archive}_$${arch}_Packages ; \
- done ; \
- done ; \
- done
-
.PHONY: update-security update-old-security update-testing-security
ST_MIRROR = http://security.debian.org/dists/$(TESTING)/updates
ST_FILE = data/packages/$(TESTING)_security_
@@ -143,24 +124,10 @@ update-security: update-old-security
done ; \
done
-update-old-security:
- for archive in $(OLDSTABLE) ; do \
- for section in main contrib non-free ; do \
- $(PYTHON) bin/apt-update-file \
- $(SEC_MIRROR)/$$archive/updates/$$section/source/Sources \
- data/packages/$${archive}_security_$${section}_Sources ; \
- for arch in $($(OLDSTABLE_uc)_ARCHS) ; do \
- $(PYTHON) bin/apt-update-file \
- $(SEC_MIRROR)/$$archive/updates/$$section/binary-$$arch/Packages \
- data/packages/$${archive}_security_$${section}_$${arch}_Packages ; \
- done ; \
- done ; \
- done
-
VOLATILE_MIRROR = http://volatile.debian.net/debian-volatile/dists
update-volatile:
- set -e && for archive in $(OLDSTABLE) $(STABLE) ; do \
- for arch in $(ETCH_ARCHS) ; do \
+ set -e && for archive in $(STABLE) ; do \
+ for arch in $(LENNY_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
$(VOLATILE_MIRROR)/$${archive}/volatile/main/binary-$$arch/Packages \
data/packages/$${archive}-volatile__main_$${arch}_Packages ; \
@@ -175,8 +142,8 @@ update-volatile:
BACKPORTS_MIRROR = http://www.backports.org/backports.org/dists
update-backports:
- set -e && for archive in $(OLDSTABLE) $(STABLE) ; do \
- for arch in $(ETCH_ARCHS) ; do \
+ set -e && for archive in $(STABLE) ; do \
+ for arch in $(LENNY_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
$(BACKPORTS_MIRROR)/$${archive}-backports/main/binary-$$arch/Packages \
data/packages/$${archive}-backports__main_$${arch}_Packages ; \

© 2014-2024 Faster IT GmbH | imprint | privacy policy