summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorHolger Levsen <holger@debian.org>2015-06-10 15:23:58 +0000
committerHolger Levsen <holger@debian.org>2015-06-10 15:23:58 +0000
commit6806c235789cae6e247498ae6b274f4f2c00e6cf (patch)
tree25a0273fd2a2410ccb48f0c34d6485f89bb3332f /Makefile
parent3c6f59d0c5fd571e0a3951a5b4498f9eb5ea24bf (diff)
always fetch Sources and Packages for all sections (Closes: #783800)
git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@34846 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile58
1 files changed, 33 insertions, 25 deletions
diff --git a/Makefile b/Makefile
index be0d74dea8..ff05c0eaf9 100644
--- a/Makefile
+++ b/Makefile
@@ -137,12 +137,14 @@ update-oldoldstable:
ST_MIRROR = http://security.debian.org/dists/$(TESTING)/updates
ST_FILE = data/packages/$(TESTING)_security_
update-testing-security:
- $(PYTHON) bin/apt-update-file \
- $(ST_MIRROR)/main/source/Sources $(ST_FILE)main_Sources
- set -e ; for arch in $($(TESTING)_ARCHS) ; do \
+ for section in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
- $(ST_MIRROR)/main/binary-$${arch}/Packages $(ST_FILE)main_$${arch}_Packages ; \
- done
+ $(ST_MIRROR)/$$section/source/Sources $(ST_FILE)$${section}_Sources ; \
+ set -e ; for arch in $($(TESTING)_ARCHS) ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(ST_MIRROR)/$$section/binary-$${arch}/Packages $(ST_FILE)$${section}_$${arch}_Packages ; \
+ done ; \
+ done
SEC_MIRROR = http://security.debian.org/dists
update-security: update-old-security update-oldold-security
@@ -191,39 +193,45 @@ update-lts: update-lts-$(OLDOLDSTABLE)
update-lts-$(OLDOLDSTABLE):
set -e && archive=$(shell echo $@ | cut -d- -f3) ; \
- for arch in $($(shell echo $@ | cut -d- -f3)_LTS_ARCHS) ; do \
+ for section in main contrib non-free ; do \
+ for arch in $($(shell echo $@ | cut -d- -f3)_LTS_ARCHS) ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(MIRROR)/dists/$${archive}-lts/$$section/binary-$$arch/Packages \
+ data/packages/$${archive}-lts__$${section}_$${arch}_Packages ; \
+ done ; \
$(PYTHON) bin/apt-update-file \
- $(MIRROR)/dists/$${archive}-lts/main/binary-$$arch/Packages \
- data/packages/$${archive}-lts__main_$${arch}_Packages ; \
- done ; \
- $(PYTHON) bin/apt-update-file \
- $(MIRROR)/dists/$${archive}-lts/main/source/Sources \
- data/packages/$${archive}-lts__main_Sources ; \
+ $(MIRROR)/dists/$${archive}-lts/$$section/source/Sources \
+ data/packages/$${archive}-lts__$${section}_Sources ; \
+ done ;
BACKPORTS_MIRROR = http://ftp.de.debian.org/debian-backports/dists
update-backports: update-backports-$(STABLE) update-backports-$(OLDSTABLE) update-backports-$(OLDOLDSTABLE)
update-backports-$(OLDOLDSTABLE):
set -e && archive=$(shell echo $@ | cut -d- -f3) ; \
- for arch in $($(shell echo $@ | cut -d- -f3)_ARCHS) ; do \
+ for section in main contrib non-free ; do \
+ for arch in $($(shell echo $@ | cut -d- -f3)_ARCHS) ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(BACKPORTS_MIRROR)/$${archive}-backports/$$section/binary-$$arch/Packages \
+ data/packages/$${archive}-backports__$${section}_$${arch}_Packages ; \
+ done ; \
$(PYTHON) bin/apt-update-file \
- $(BACKPORTS_MIRROR)/$${archive}-backports/main/binary-$$arch/Packages \
- data/packages/$${archive}-backports__main_$${arch}_Packages ; \
- done ; \
- $(PYTHON) bin/apt-update-file \
- $(BACKPORTS_MIRROR)/$${archive}-backports/main/source/Sources \
- data/packages/$${archive}-backports__main_Sources ; \
+ $(BACKPORTS_MIRROR)/$${archive}-backports/$$section/source/Sources \
+ data/packages/$${archive}-backports__$${section}_Sources ; \
+ done ;
update-backports-%:
set -e && archive=$(shell echo $@ | cut -d- -f3) ; \
- for arch in $($(shell echo $@ | cut -d- -f3)_ARCHS) ; do \
+ for section in main contrib non-free ; do \
+ for arch in $($(shell echo $@ | cut -d- -f3)_ARCHS) ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(MIRROR)/dists/$${archive}-backports/$$section/binary-$$arch/Packages \
+ data/packages/$${archive}-backports__main_$${arch}_Packages ; \
+ done ; \
$(PYTHON) bin/apt-update-file \
- $(MIRROR)/dists/$${archive}-backports/main/binary-$$arch/Packages \
- data/packages/$${archive}-backports__main_$${arch}_Packages ; \
- done ; \
- $(PYTHON) bin/apt-update-file \
- $(MIRROR)/dists/$${archive}-backports/main/source/Sources \
+ $(MIRROR)/dists/$${archive}-backports/$$section/source/Sources \
data/packages/$${archive}-backports__main_Sources ; \
+ done ; \
update-lists:
svn update -q data

© 2014-2024 Faster IT GmbH | imprint | privacy policy