summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRaphael Geissert <atomo64@gmail.com>2013-05-06 09:03:31 +0000
committerRaphael Geissert <atomo64@gmail.com>2013-05-06 09:03:31 +0000
commit4f996047708fc3ed7a891343b26f8b20e13be02e (patch)
tree912964667d30bbf1ba298f6123bf7fa1a06b2d1e /Makefile
parent2679a00425a39d8897ca9bf9581b1afa4288f042 (diff)
Do update oldstable lists
Get rid of volatile while at it and update the code for new location of stable backports git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@22182 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile33
1 files changed, 14 insertions, 19 deletions
diff --git a/Makefile b/Makefile
index 1f78751b6c..da620449f4 100644
--- a/Makefile
+++ b/Makefile
@@ -78,7 +78,7 @@ update-testing:
done ; \
done
-update-stable:
+update-stable: update-oldstable
set -e ; for rel in $(STABLE) ; do \
for archive in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
@@ -122,7 +122,7 @@ update-testing-security:
done
SEC_MIRROR = http://security.debian.org/dists
-update-security:
+update-security: update-old-security
for archive in $(STABLE); do \
for section in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
@@ -150,34 +150,29 @@ update-old-security:
done ; \
done
-VOLATILE_MIRROR = http://volatile.debian.org/debian-volatile/dists
-update-volatile:
- set -e && for archive in lenny ; do \
- for arch in $(LENNY_ARCHS) ; do \
+BACKPORTS_MIRROR = http://ftp.de.debian.org/debian-backports/dists
+update-backports: update-backports-$(STABLE) update-backports-$(OLDSTABLE)
+
+update-backports-$(OLDSTABLE):
+ set -e && archive=$(shell echo $@ | cut -d- -f3) ; \
+ for arch in $($(shell echo $@ | cut -d- -f3)_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
- $(VOLATILE_MIRROR)/$${archive}/volatile/main/binary-$$arch/Packages \
- data/packages/$${archive}-volatile__main_$${arch}_Packages ; \
+ $(BACKPORTS_MIRROR)/$${archive}-backports/main/binary-$$arch/Packages \
+ data/packages/$${archive}-backports__main_$${arch}_Packages ; \
done ; \
$(PYTHON) bin/apt-update-file \
- $(VOLATILE_MIRROR)/$${archive}/volatile/main/source/Sources \
- data/packages/$${archive}-volatile__main_Sources ; \
- done
- $(PYTHON) bin/apt-update-file \
- $(VOLATILE_MIRROR)/lenny/volatile/main/binary-armel/Packages \
- data/packages/lenny-volatile__main_armel_Packages
-
-BACKPORTS_MIRROR = http://ftp.de.debian.org/debian-backports/dists
-update-backports: update-backports-$(STABLE)
+ $(BACKPORTS_MIRROR)/$${archive}-backports/main/source/Sources \
+ data/packages/$${archive}-backports__main_Sources ; \
update-backports-%:
set -e && archive=$(shell echo $@ | cut -d- -f3) ; \
for arch in $($(shell echo $@ | cut -d- -f3)_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
- $(BACKPORTS_MIRROR)/$${archive}-backports/main/binary-$$arch/Packages \
+ $(MIRROR)/dists/$${archive}-backports/main/binary-$$arch/Packages \
data/packages/$${archive}-backports__main_$${arch}_Packages ; \
done ; \
$(PYTHON) bin/apt-update-file \
- $(BACKPORTS_MIRROR)/$${archive}-backports/main/source/Sources \
+ $(MIRROR)/dists/$${archive}-backports/main/source/Sources \
data/packages/$${archive}-backports__main_Sources ; \
update-lists:

© 2014-2024 Faster IT GmbH | imprint | privacy policy