summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThijs Kinkhorst <thijs@debian.org>2011-02-10 06:54:30 +0000
committerThijs Kinkhorst <thijs@debian.org>2011-02-10 06:54:30 +0000
commit14cdc1a4c258585d893b74db4285a21bd81932bc (patch)
treeeec6c9fcf3d0771f25c9909e88a197d11fa4a09b /Makefile
parent34a22e4578caea455c0ef4fac7a0ca1f9183ecf0 (diff)
update makefile for squeeze release
git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@16093 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile44
1 files changed, 38 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 60f23bc752..83d566218c 100644
--- a/Makefile
+++ b/Makefile
@@ -10,9 +10,11 @@ LENNY_ARCHS = alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 spar
SQUEEZE_ARCHS = amd64 armel i386 ia64 mips mipsel powerpc s390 sparc
SID_ARCHS = alpha amd64 armel hppa i386 ia64 kfreebsd-i386 kfreebsd-amd64 mips mipsel powerpc s390 sparc
-STABLE = lenny
-TESTING = squeeze
+OLDSTABLE = lenny
+STABLE = squeeze
+TESTING = wheezy
+OLDSTABLE_uc = $(shell echo "$(OLDSTABLE)" | tr "[:lower:]" "[:upper:]")
STABLE_uc = $(shell echo "$(STABLE)" | tr "[:lower:]" "[:upper:]")
TESTING_uc = $(shell echo "$(TESTING)" | tr "[:lower:]" "[:upper:]")
@@ -49,7 +51,7 @@ stamps/DTSA-syntax: data/DTSA/list bin/check-syntax $(PYTHON_MODULES)
serve:
@bash bin/test-web-server
-.PHONY: update-packages update-testing update-stable
+.PHONY: update-packages update-testing update-stable update-oldstable
update-packages: update-testing
set -e ; for rel in sid experimental ; do \
for archive in main contrib non-free ; do \
@@ -82,7 +84,7 @@ update-testing:
done ; \
done
-update-stable:
+update-stable: update-oldstable
set -e ; for rel in $(STABLE) ; do \
for archive in main contrib non-free ; do \
$(PYTHON) bin/apt-update-file \
@@ -98,6 +100,22 @@ update-stable:
done ; \
done
+update-oldstable:
+ set -e ; for rel in $(OLDSTABLE) ; do \
+ for archive in main contrib non-free ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(MIRROR)/dists/$$rel/$$archive/source/Sources \
+ data/packages/$${rel}__$${archive}_Sources ; \
+ done ; \
+ for arch in $($(OLDSTABLE_uc)_ARCHS) ; do \
+ for archive in main contrib non-free ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(MIRROR)/dists/$$rel/$$archive/binary-$$arch/Packages \
+ data/packages/$${rel}__$${archive}_$${arch}_Packages ; \
+ done ; \
+ done ; \
+ done
+
.PHONY: update-security update-old-security update-testing-security
ST_MIRROR = http://security.debian.org/dists/$(TESTING)/updates
ST_FILE = data/packages/$(TESTING)_security_
@@ -124,6 +142,20 @@ update-security: update-old-security
done ; \
done
+update-old-security:
+ for archive in $(OLDSTABLE); do \
+ for section in main contrib non-free ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(SEC_MIRROR)/$$archive/updates/$$section/source/Sources \
+ data/packages/$${archive}_security_$${section}_Sources ; \
+ for arch in $($(OLDSTABLE_uc)_ARCHS) ; do \
+ $(PYTHON) bin/apt-update-file \
+ $(SEC_MIRROR)/$$archive/updates/$$section/binary-$$arch/Packages \
+ data/packages/$${archive}_security_$${section}_$${arch}_Packages ; \
+ done ; \
+ done ; \
+ done
+
VOLATILE_MIRROR = http://volatile.debian.net/debian-volatile/dists
update-volatile:
set -e && for archive in $(STABLE) ; do \
@@ -142,8 +174,8 @@ update-volatile:
BACKPORTS_MIRROR = http://www.backports.org/backports.org/dists
update-backports:
- set -e && for archive in $(STABLE) ; do \
- for arch in $(LENNY_ARCHS) ; do \
+ set -e && for archive in $(OLDSTABLE) $(STABLE) ; do \
+ for arch in $(SQUEEZE_ARCHS) ; do \
$(PYTHON) bin/apt-update-file \
$(BACKPORTS_MIRROR)/$${archive}-backports/main/binary-$$arch/Packages \
data/packages/$${archive}-backports__main_$${arch}_Packages ; \

© 2014-2024 Faster IT GmbH | imprint | privacy policy