aboutsummaryrefslogtreecommitdiffstats
path: root/spanish/Makefile
diff options
context:
space:
mode:
authorSpanish Language Team <spanish>1998-09-23 00:08:04 +0000
committerSpanish Language Team <spanish>1998-09-23 00:08:04 +0000
commit4b2059fc201ec66b9a8a4e3e452fd48557c4b1a1 (patch)
tree742ef5facffd7a02fc681451f96e12bb4ed02e02 /spanish/Makefile
parent761250996dab23d4f4259e933d39aa7cdec578f6 (diff)
Spanish translation of the root directory added.
CVS version numbers spanish/Make.lang: INITIAL -> 1.1 spanish/Make.templ.inc: INITIAL -> 1.1 spanish/Makefile: INITIAL -> 1.1 spanish/contact.wml: INITIAL -> 1.1 spanish/developers_corner.wml: INITIAL -> 1.1 spanish/donations.wml: INITIAL -> 1.1 spanish/index.wml: INITIAL -> 1.1 spanish/license.wml: INITIAL -> 1.1 spanish/news.wml: INITIAL -> 1.1 spanish/news1997.wml: INITIAL -> 1.1 spanish/related_links.wml: INITIAL -> 1.1 spanish/social_contract.wml: INITIAL -> 1.1 spanish/support.wml: INITIAL -> 1.1
Diffstat (limited to 'spanish/Makefile')
-rw-r--r--spanish/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/spanish/Makefile b/spanish/Makefile
new file mode 100644
index 00000000000..882640c93af
--- /dev/null
+++ b/spanish/Makefile
@@ -0,0 +1,31 @@
+BASE=.
+HTMLDIR=$(BASE)/../../debian.org
+TEMPLDIR=$(BASE)/template/debian
+ENGLISHSRCDIR=$(BASE)/../english
+
+include $(BASE)/Make.lang
+
+WMLFILES := $(wildcard *.wml)
+HTMLFILES := $(patsubst %.wml,$(HTMLDIR)/%.html.$(LANGUAGE),$(WMLFILES))
+
+# EPILOG=--epilog=weblint
+$(HTMLDIR)/%.html.$(LANGUAGE) : %.wml $(TEMPLDIR)/template.wml $(TEMPLDIR)/languages.wml
+ wml -q $(EPILOG) $(<F)
+
+all: $(HTMLFILES)
+ ( cd 2.0; $(MAKE) )
+ ( cd MailingLists; $(MAKE) )
+ ( cd News; $(MAKE) )
+ ( cd SPI; $(MAKE) )
+ ( cd devel; $(MAKE) )
+ ( cd distrib; $(MAKE) )
+ ( cd doc; $(MAKE) )
+ ( cd intro; $(MAKE) )
+ ( cd logos; $(MAKE) )
+ ( cd ports; $(MAKE) )
+ ( cd security; $(MAKE) )
+
+include $(BASE)/Make.templ.inc
+
+$(HTMLDIR)/index.html.$(LANGUAGE): index.wml $(HTMLDIR)/News/index.html.$(LANGUAGE) $(TEMPLDIR)/mainpage.wml $(TEMPLDIR)/ctime.wml $(TEMPLDIR)/recent_news.wml $(TEMPLDIR)/languages.wml
+ wml -q index.wml

© 2014-2024 Faster IT GmbH | imprint | privacy policy