aboutsummaryrefslogtreecommitdiffstats
path: root/norwegian/Make.common
diff options
context:
space:
mode:
authorNorwegian Language Team <norwegian>1999-07-09 11:17:16 +0000
committerNorwegian Language Team <norwegian>1999-07-09 11:17:16 +0000
commitd07a591d30bb85fc1f0dda142461c6e0695271be (patch)
tree298fe3d65c16623ebbdfb85ba22da2b771f7302e /norwegian/Make.common
parentf416c76b39779b12312ac64826efc8cb1ec3f0f5 (diff)
Addition of Makefiles, and .wmlrcNorwegian
CVS version numbers norwegian/.wmlrc: 1.1 -> 1.1.1.1 norwegian/Make.common: 1.1 -> 1.1.1.1 norwegian/Make.dep.generic: 1.1 -> 1.1.1.1 norwegian/Make.dep.templ: 1.1 -> 1.1.1.1 norwegian/Makefile: 1.1 -> 1.1.1.1 norwegian/donations.wml: 1.1.1.1 -> 1.1.1.2 norwegian/Bugs/Makefile: 1.1 -> 1.1.1.1 norwegian/MailingLists/Makefile: 1.1 -> 1.1.1.1 norwegian/News/Makefile: 1.1 -> 1.1.1.1 norwegian/News/1997/Makefile: 1.1 -> 1.1.1.1 norwegian/News/1998/Makefile: 1.1 -> 1.1.1.1 norwegian/News/1999/Makefile: 1.1 -> 1.1.1.1 norwegian/News/weekly/Makefile: 1.1 -> 1.1.1.1 norwegian/Pics/Makefile: 1.1 -> 1.1.1.1 norwegian/consultants/Makefile: 1.1 -> 1.1.1.1 norwegian/devel/Makefile: 1.1 -> 1.1.1.1 norwegian/distrib/Makefile: 1.1 -> 1.1.1.1 norwegian/doc/Makefile: 1.1 -> 1.1.1.1 norwegian/events/Makefile: 1.1 -> 1.1.1.1 norwegian/events/1998/Makefile: 1.1 -> 1.1.1.1 norwegian/events/1999/Makefile: 1.1 -> 1.1.1.1 norwegian/intro/Makefile: 1.1 -> 1.1.1.1 norwegian/logos/Makefile: 1.1 -> 1.1.1.1 norwegian/mirror/Makefile: 1.1 -> 1.1.1.1 norwegian/misc/Makefile: 1.1 -> 1.1.1.1 norwegian/partners/Makefile: 1.1 -> 1.1.1.1 norwegian/partners/images/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/alpha/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/arm/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/beowulf/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/hurd/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/mips/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/powerpc/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/powerpc/pics/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/sparc/Makefile: 1.1 -> 1.1.1.1 norwegian/ports/sparc64/Makefile: 1.1 -> 1.1.1.1 norwegian/releases/Makefile: 1.1 -> 1.1.1.1 norwegian/releases/hamm/Makefile: 1.1 -> 1.1.1.1 norwegian/releases/potato/Makefile: 1.1 -> 1.1.1.1 norwegian/releases/slink/Makefile: 1.1 -> 1.1.1.1 norwegian/security/Makefile: 1.1 -> 1.1.1.1 norwegian/security/1997/Makefile: 1.1 -> 1.1.1.1 norwegian/security/1998/Makefile: 1.1 -> 1.1.1.1 norwegian/security/1999/Makefile: 1.1 -> 1.1.1.1 norwegian/security/undated/Makefile: 1.1 -> 1.1.1.1 norwegian/vote/Makefile: 1.1 -> 1.1.1.1 norwegian/vote/1999/Makefile: 1.1 -> 1.1.1.1 norwegian/y2k/Makefile: 1.1 -> 1.1.1.1
Diffstat (limited to 'norwegian/Make.common')
-rw-r--r--norwegian/Make.common65
1 files changed, 65 insertions, 0 deletions
diff --git a/norwegian/Make.common b/norwegian/Make.common
new file mode 100644
index 00000000000..69719e77e68
--- /dev/null
+++ b/norwegian/Make.common
@@ -0,0 +1,65 @@
+# Nothing in here should require any modification
+# If you feel you need to modify something send mail
+# to debian-www explaining why so that others can benefit
+# from your improvements
+
+RELHTMLBASE=../../debian.org
+RELTEMPLDIR=../english/template/debian
+
+HTMLDIR=$(WMLBASE)/$(RELHTMLBASE)/$(CUR_DIR)
+TEMPLDIR=$(WMLBASE)/$(RELTEMPLDIR)
+# Do Not modify the following line
+ENGLISHSRCDIR=$(WMLBASE)/../english
+
+WMLFILES := $(wildcard *.wml)
+HTMLFILES := $(patsubst %.wml,%.$(LANGUAGE).html,$(WMLFILES))
+HTMLDESTFILES := $(patsubst %.wml,$(HTMLDIR)/%.$(LANGUAGE).html,$(WMLFILES))
+JPGSOURCE := $(wildcard *.jpg)
+JPGDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(JPGSOURCE))
+GIFSOURCE := $(wildcard *.gif)
+GIFDESTFILES := $(patsubst %,$(HTMLDIR)/%,$(GIFSOURCE))
+IMGFILES := $(JPGSOURCE) $(GIFSOURCE)
+IMGDESTFILES := $(JPGDESTFILES) $(GIFDESTFILES)
+
+all:: $(HTMLFILES)
+ @for i in $(SUBS) ''; do \
+ if [ -d "$$i" ]; then \
+ $(MAKE) -C $$i ; \
+ fi ; \
+ done
+
+install::
+ -install -d $(HTMLDIR)
+install:: $(HTMLDESTFILES) $(IMGDESTFILES)
+ @for i in $(SUBS) ''; do \
+ if [ -d "$$i" ]; then \
+ $(MAKE) -C $$i install; \
+ fi ; \
+ done
+
+clean::
+ rm -f *.$(LANGUAGE).html
+ @for i in $(SUBS) ''; do \
+ if [ -d "$$i" ]; then \
+ $(MAKE) -C $$i clean; \
+ fi ; \
+ done
+
+cleandest::
+ rm -f $(HTMLDIR)/*.$(LANGUAGE).html
+ @for i in $(SUBS) ''; do \
+ if [ -d "$$i" ]; then \
+ $(MAKE) -C $$i cleandest; \
+ fi ; \
+ done
+
+$(HTMLDIR)/%.$(LANGUAGE).html: %.$(LANGUAGE).html
+ @echo copying $(@F) to $(HTMLDIR)
+ -@cp $(@F) $(HTMLDIR)
+ifeq ($(LANGUAGE),en)
+ @echo making a link $(@D)/$(*F).html -\> $(@F)
+ -@ln -f -s $(@F) $(@D)/$(*F).html
+endif
+
+$(IMGDESTFILES): $(IMGFILES)
+ cp $(@F) $(HTMLDIR)

© 2014-2024 Faster IT GmbH | imprint | privacy policy