aboutsummaryrefslogtreecommitdiffstats
path: root/italian/Makefile
diff options
context:
space:
mode:
authorItalian Language Team <italian>1998-08-25 09:20:56 +0000
committerItalian Language Team <italian>1998-08-25 09:20:56 +0000
commit2679ae69a6d39c63079f97b523f8b8e2b692f114 (patch)
treefd779f12f2f3b0c7639ddf147df99e2466516ec7 /italian/Makefile
parent44f4f9c69eb2398658627f4cfb2bd6920d4684f1 (diff)
Modified Files:
Makefile Added Files: Make.templ.inc 2.0/Makefile MailingLists/Makefile Temp/Makefile.old Temp/Readme.1st devel/Makefile distrib/Makefile doc/Makefile intro/Makefile logos/Makefile ports/Makefile security/Makefile Grossa revisione del cvs: - aggiunta di un Makefile per ognuna della directory. - non e` piu` necessario aggiornare il Makefile principale per aggiungere le nuove traduzioni (finalmente :) CVS version numbers italian/Make.templ.inc: INITIAL -> 1.1 italian/Makefile: 1.13 -> 1.14 italian/MailingLists/Makefile: INITIAL -> 1.1 italian/Temp/Makefile.old: INITIAL -> 1.1 italian/Temp/Readme.1st: INITIAL -> 1.1 italian/devel/Makefile: INITIAL -> 1.1 italian/distrib/Makefile: INITIAL -> 1.1 italian/doc/Makefile: INITIAL -> 1.1 italian/intro/Makefile: INITIAL -> 1.1 italian/logos/Makefile: INITIAL -> 1.1 italian/ports/Makefile: INITIAL -> 1.1 italian/security/Makefile: INITIAL -> 1.1
Diffstat (limited to 'italian/Makefile')
-rw-r--r--italian/Makefile123
1 files changed, 28 insertions, 95 deletions
diff --git a/italian/Makefile b/italian/Makefile
index 055ab138605..559de620538 100644
--- a/italian/Makefile
+++ b/italian/Makefile
@@ -1,98 +1,31 @@
+# Translators should only need to change the LANG variable
LANG=it
-HTMLDIR=../../debian.org
-TEMPLDIR=template/debian
-ENGLISHSRCDIR=../english
-# EPILOG=--epilog=weblint
-$(HTMLDIR)/%.html.$(LANG) : %.wml $(TEMPLDIR)/template.wml
- cd $(<D) && wml $(EPILOG) $(<F)
-# cd $(<D) && wml -o $@ $(EPILOG) $(<F)
-
-# translators should comment out the line for any file they haven't translated.
-all:\
- $(HTMLDIR)/contact.html.$(LANG) \
- $(HTMLDIR)/index.html.$(LANG) \
- $(HTMLDIR)/license.html.$(LANG) \
- $(HTMLDIR)/social_contract.html.$(LANG) \
- $(HTMLDIR)/support.html.$(LANG) \
- $(HTMLDIR)/developers_corner.html.$(LANG) \
- $(HTMLDIR)/2.0/errata.html.$(LANG) \
- $(HTMLDIR)/2.0/2.0beta_CD.html.$(LANG) \
- $(HTMLDIR)/2.0/HOWTO.upgrade.html.$(LANG) \
- $(HTMLDIR)/MailingLists/debian-announce.html.$(LANG) \
- $(HTMLDIR)/devel/HOWTO_translate.html.$(LANG) \
- $(HTMLDIR)/devel/extract_key.html.$(LANG) \
- $(HTMLDIR)/devel/help.html.$(LANG) \
- $(HTMLDIR)/devel/incoming_mirrors.html.$(LANG) \
- $(HTMLDIR)/devel/maintainer_contacts.html.$(LANG) \
- $(HTMLDIR)/devel/mirror.html.$(LANG) \
- $(HTMLDIR)/devel/people.html.$(LANG) \
- $(HTMLDIR)/devel/release_info.html.$(LANG) \
- $(HTMLDIR)/devel/rsync_examples.html.$(LANG) \
- $(HTMLDIR)/intro/about.html.$(LANG) \
- $(HTMLDIR)/intro/cooperation.html.$(LANG) \
- $(HTMLDIR)/intro/international.html.$(LANG) \
- $(HTMLDIR)/intro/license_disc.html.$(LANG) \
- $(HTMLDIR)/intro/cn.html.$(LANG) \
- $(HTMLDIR)/intro/free.html.$(LANG) \
- $(HTMLDIR)/intro/why_debian.html.$(LANG) \
- $(HTMLDIR)/logos/index.html.$(LANG) \
- $(HTMLDIR)/security/index.html.$(LANG) \
-# $(HTMLDIR)/MailingLists/subscribe.html.$(LANG) \
-# $(HTMLDIR)/MailingLists/unsubscribe.html.$(LANG) \
-# $(HTMLDIR)/devel/mirror_submit.html.$(LANG) \
-# $(HTMLDIR)/devel/ports.html.$(LANG) \
-# $(HTMLDIR)/donations.html.$(LANG) \
-# $(HTMLDIR)/news.html.$(LANG) \
-# $(HTMLDIR)/news1997.html.$(LANG) \
-# $(HTMLDIR)/related_links.html.$(LANG) \
-# $(HTMLDIR)/sponsor.html \
-# $(HTMLDIR)/doc/index.html.$(LANG) \
-# $(HTMLDIR)/distrib/distrib.html.$(LANG) \
-# $(HTMLDIR)/distrib/ftplist.html.$(LANG) \
-# $(HTMLDIR)/distrib/packages.html.$(LANG) \
-# $(HTMLDIR)/distrib/vendors.html.$(LANG) \
-# $(HTMLDIR)/
-
-
-#
-# TRANSLATORS SHOULD NOT HAVE TO TOUCH ANYTHING BELOW THIS LINE
-#
-
-$(HTMLDIR)/index.html.$(LANG): index.wml ../english/news.wml $(TEMPLDIR)/mainpage.wml $(TEMPLDIR)/ctime.wml
- wml index.wml
-
-# with no rule, the default ruleset (at the top) is used
-$(HTMLDIR)/devel/people.html.$(LANG): devel/people.wml $(ENGLISHSRCDIR)/devel/people.names
-
-
-# template dependencies
-
-template/debian/basic.wml: template/debian/navbar.wml
- touch template/debian/basic.wml
-template/debian/footer.wml: template/debian/ctime.wml
- touch template/debian/footer.wml
+BASE=.
+HTMLDIR=$(BASE)/../../debian.org
+TEMPLDIR=$(BASE)/template/debian
+ENGLISHSRCDIR=$(BASE)/../english
-# template/debian/languages.wml: template/debian/
-# touch template/debian/languages.wml
-
-template/debian/menubar.wml: template/debian/footer.wml
- touch template/debian/menubar.wml
-
-# template/debian/recent_news.wml: template/debian/
-# touch template/debian/recent_news.wml
-
-# template/debian/ctime.wml: template/debian/
-# touch template/debian/ctime.wml
-
-template/debian/mainpage.wml: template/debian/basic.wml template/debian/menubar.wml
- touch template/debian/mainpage.wml
-
-# template/debian/navbar.wml: template/debian/
-# touch template/debian/navbar.wml
-
-template/debian/template.wml: template/debian/basic.wml template/debian/footer.wml
- touch template/debian/template.wml
-
-people: devel/people.wml
- cd devel && wml people.wml
+# EPILOG=--epilog=weblint
+$(HTMLDIR)/%.html.$(LANG) : %.wml $(TEMPLDIR)/template.wml
+ wml -q $(EPILOG) $(<F)
+
+WMLFILES := $(wildcard *.wml)
+HTMLFILES := $(patsubst %.wml,$(HTMLDIR)/%.html.$(LANG),$(WMLFILES))
+
+all: $(HTMLFILES)
+ ( cd 2.0; make )
+ ( cd MailingLists; make )
+ ( cd SPI; make )
+ ( cd devel; make )
+ ( cd distrib; make )
+ ( cd doc; make )
+ ( cd intro; make )
+ ( cd logos; make )
+ ( cd ports; make )
+ ( cd security; make )
+
+include $(BASE)/Make.templ.inc
+
+$(HTMLDIR)/index.html.$(LANG): index.wml news.wml $(TEMPLDIR)/mainpage.wml $(TEMPLDIR)/ctime.wml
+ wml -q index.wml

© 2014-2024 Faster IT GmbH | imprint | privacy policy