aboutsummaryrefslogtreecommitdiffstats
path: root/catalan/Makefile
diff options
context:
space:
mode:
authorMartin Schulze <joey>2001-07-26 10:24:52 +0000
committerMartin Schulze <joey>2001-07-26 10:24:52 +0000
commit7f670a67d916387bb0a5c34fe40f179f3d06d586 (patch)
treefd2e1c1f4eea1a2cafeaf140a83b91e5d07f8add /catalan/Makefile
parent3317310c2f3dfda2aef4258823187ceffb1ca41f (diff)
Sync with english version
CVS version numbers arabic/Makefile: 1.13 -> 1.14 catalan/Makefile: 1.1 -> 1.2 chinese/Makefile: 1.28 -> 1.29 croatian/Makefile: 1.33 -> 1.34 danish/Makefile: 1.20 -> 1.21 dutch/Makefile: 1.14 -> 1.15 esperanto/Makefile: 1.16 -> 1.17 finnish/Makefile: 1.20 -> 1.21 french/Makefile: 1.32 -> 1.33 german/Makefile: 1.35 -> 1.36 greek/Makefile: 1.11 -> 1.12 hungarian/Makefile: 1.17 -> 1.18 italian/Makefile: 1.40 -> 1.41 japanese/Makefile: 1.36 -> 1.37 korean/Makefile: 1.19 -> 1.20 norwegian/Makefile: 1.17 -> 1.18 polish/Makefile: 1.22 -> 1.23 portuguese/Makefile: 1.20 -> 1.21 russian/Makefile: 1.17 -> 1.18 spanish/Makefile: 1.32 -> 1.33 swedish/Makefile: 1.24 -> 1.25 turkish/Makefile: 1.16 -> 1.17
Diffstat (limited to 'catalan/Makefile')
-rw-r--r--catalan/Makefile59
1 files changed, 53 insertions, 6 deletions
diff --git a/catalan/Makefile b/catalan/Makefile
index e3889a27dd9..a3a5e20e700 100644
--- a/catalan/Makefile
+++ b/catalan/Makefile
@@ -4,15 +4,30 @@
WMLBASE=.
CUR_DIR=
-SUBS=Bugs MailingLists News Pics consultants devel distrib doc events intro \
-international logos mirror misc partners ports releases security vote y2k \
-chinese searchtmpl
+SUBS=Bugs MailingLists News Pics banners chinese consultants devel distrib \
+doc events intro international logos mirror misc partners ports releases \
+searchtmpl security vote y2k
+
+ifneq "$(wildcard om_svenska/Makefile)" ""
+SUBS += om_svenska
+endif
include $(WMLBASE)/Make.lang
-CUR_YEAR ?= $(shell date +%Y)
+ifndef SUBLANG
+SITEMAP = sitemap.$(LANGUAGE).html
+HTMLMAP = $(HTMLDIR)/$(SITEMAP)
+else
+SITEMAP = $(sort $(foreach i,$(SUBLANG),\
+ $(patsubst %.wml,%.$(LANGUAGE)-$(i).html,sitemap.wml)))
+HTMLMAP = $(patsubst %.html,$(HTMLDIR)/%.html,$(SITEMAP))
+endif
+
+ifeq "$(LANGUAGE)" "en"
+IMGFILES += favicon.ico
+IMGDESTFILES += $(HTMLDIR)/favicon.ico
+endif
-# Do Not modify the following line
index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/mainpage.wml \
$(wildcard News/$(CUR_YEAR)/[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/News/$(CUR_YEAR)/[0-9]*.wml) \
$(wildcard security/$(CUR_YEAR)/dsa-[0-9]*.wml) $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-[0-9]*.wml) \
@@ -20,5 +35,37 @@ index.$(LANGUAGE).html: index.wml $(TEMPLDIR)/mainpage.wml \
$(ENGLISHSRCDIR)/releases/info
$(WML) index.wml
-install::
+$(SITEMAP): $(ENGLISHDIR)/sitemap.wml \
+ $(TEMPLDIR)/links.tags.wml $(TEMPLDIR)/template.wml \
+ $(ENGLISHDIR)/releases/info $(ENGLISHDIR)/MailingLists/mklist.tags
+ifeq "$(LANGUAGE)" "zh"
+ $(shell echo $(WML) | sed s/:.zh/:sitemap.zh/g) \
+ $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml \
+ $(shell egrep '^-D (CUR_|CHAR)' .wmlrc)
+ @echo -n " * Converting: [zh_CN.GB2312], "
+ @$(B5TOGB) < sitemap.zh-cn.html.tmp > sitemap.zh-cn.html
+ @rm -f sitemap.zh-cn.html.tmp
+ @$(TOCN) sitemap.zh-cn.html
+ @echo -n "[zh_HK.Big5], "
+ @mv -f sitemap.zh-hk.html.tmp sitemap.zh-hk.html
+ @$(TOHK) sitemap.zh-hk.html
+ @echo "[zh_TW.Big5]."
+ @mv -f sitemap.zh-tw.html.tmp sitemap.zh-tw.html
+ @$(TOTW) sitemap.zh-tw.html
+else
+ifeq "$(LANGUAGE)" "ja"
+ wml -q -D CUR_YEAR=2001 -o UNDEFuJA:sitemap.ja.html.tmp@g+w \
+ --prolog="/usr/bin/kcc -e -" --epilog="./convert sitemap.ja.html" \
+ ../english/sitemap.wml \
+ -D CUR_LANG=Japanese -D CUR_ISO_LANG=ja -D CHARSET=iso-2022-jp
+else
+ $(shell echo $(WML) | sed s/index/sitemap/) \
+ $(shell echo $(ENGLISHDIR) | sed s,./,,)/sitemap.wml \
+ $(shell egrep '^-D (CUR_|CHAR)' .wmlrc)
+endif
+endif
+
+all:: $(SITEMAP)
+
+install:: $(HTMLMAP)
test -L $(HTMLDIR)/intl || ln -sf international $(HTMLDIR)/intl

© 2014-2024 Faster IT GmbH | imprint | privacy policy