summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPetter Reinholdtsen <pere@debian.org>2016-12-22 11:23:31 +0000
committerPetter Reinholdtsen <pere@debian.org>2016-12-22 11:23:31 +0000
commitc10fd9739ba87f3cf5c41a42bde5a2e168431996 (patch)
tree4605bd6808b6888962f5f510cdac0c6cd467ebf9 /Makefile
parent8d9b3cfab3128f7fe970935cdffa3e8fc55f781b (diff)
Document how to run bin/compare-nvd-cve.
git-svn-id: svn+ssh://svn.debian.org/svn/secure-testing@47337 e39458fd-73e7-0310-bf30-c45bca0a0e42
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7d296c7afb..4e56cd3d66 100644
--- a/Makefile
+++ b/Makefile
@@ -247,4 +247,15 @@ update-nvd:
done
python bin/update-nvd data/nvd/nvdcve-*.xml
+# Experimental code to compare the Debian and NVD CVE databases using
+# CPE values as common key.
+update-compare-nvd:
+ mkdir -p data/nvd2
+ for x in $$(seq 2002 $$(date +%Y)) ; do \
+ name=nvdcve-2.0-$$x.xml.gz; \
+ wget -q -Odata/nvd2/$$name https://static.nvd.nist.gov/feeds/xml/cve/$$name || true ; \
+ gzip -f -d data/nvd2/$$name || true; \
+ done
+ bin/compare-nvd-cve 2> compare-nvd-cve.log
+
update-all: update-nvd update-lists update-packages update-oldstable update-stable update-security update-testing-security update-packages update-backports all

© 2014-2024 Faster IT GmbH | imprint | privacy policy