summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHisham Muhammad <hisham@gobolinux.org>2011-11-21 02:52:41 +0000
committerHisham Muhammad <hisham@gobolinux.org>2011-11-21 02:52:41 +0000
commitbc87a8ff8c5b6374a00a950cd15e1b290d6c5e06 (patch)
tree616bbb782feaabc04d48c963ff1b4b1cfec5b267 /configure.ac
parent7ca10817122d3b7b30fabb1cadb75e5ee14b364e (diff)
Remove bundled hwloc-1.2.1. Use either native Linux affinity support or an external libhwloc.
(for details see https://sourceforge.net/mailarchive/forum.php?thread_name=CAJpkDYeZpwqcWxZ77wq6bMrnhn-KzkU1xAqb3cU0drfnA3n9FQ%40mail.gmail.com&forum_name=htop-general )
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 3 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 514c458d..83a096ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,32 +131,12 @@ if test "x$enable_native_affinity" = xyes; then
[AC_MSG_RESULT([no])])
fi
-##### hwloc
-AC_ARG_ENABLE(system-hwloc, [AC_HELP_STRING([--enable-system-hwloc], [use the copy of hwloc from your system and not the one bundled with the htop sources. (hwloc required)])], ,enable_system_hwloc="no")
-enable_xml=no
-AC_ARG_ENABLE(hwloc, [AC_HELP_STRING([--enable-hwloc], [enable hwloc support for CPU affinity])],, test "x$enable_native_affinity" = xno && enable_hwloc="yes")
+AC_ARG_ENABLE(hwloc, [AC_HELP_STRING([--enable-hwloc], [enable hwloc support for CPU affinity])],, enable_hwloc="no")
if test "x$enable_hwloc" = xyes
then
- if test "x$enable_system_hwloc" = xyes
- then
- AC_CHECK_LIB([hwloc], [hwloc_linux_get_tid_cpubind], [], [missing_libraries="$missing_libraries libhwloc"])
- AC_CHECK_HEADERS([hwloc.h],[:], [missing_headers="$missing_headers $ac_header"])
-
- else
- HWLOC_SETUP_CORE([hwloc-1.2.1], [hwloc_bundled=yes], [hwloc_bundled=no])
- fi
+ AC_CHECK_LIB([hwloc], [hwloc_linux_get_tid_cpubind], [], [missing_libraries="$missing_libraries libhwloc"])
+ AC_CHECK_HEADERS([hwloc.h],[:], [missing_headers="$missing_headers $ac_header"])
fi
-HWLOC_DO_AM_CONDITIONALS
-AM_CONDITIONAL([HAVE_HWLOC], [test "x$hwloc_bundled" = "xyes" -o "x$hwloc_system" = "xyes"])
-AM_CONDITIONAL([HAVE_BUNDLED_HWLOC], [test "x$hwloc_bundled" = "xyes"])
-if test "x$hwloc_system" = "xyes"; then
- AC_DEFINE([HAVE_SYSTEM_HWLOC], 1, [Have system hwloc])
- AC_DEFINE([HAVE_HWLOC], 1, [Have hwloc])
-elif test "x$hwloc_bundled" = "xyes"; then
- AC_DEFINE([HAVE_BUNDLED_HWLOC], 1, [Use bundled hwloc])
- AC_DEFINE([HAVE_HWLOC], 1, [Have hwloc])
-fi
-#####
AC_CONFIG_FILES([Makefile htop.1])
AC_OUTPUT

© 2014-2024 Faster IT GmbH | imprint | privacy policy