summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHisham Muhammad <hisham@gobolinux.org>2008-03-05 09:46:47 +0000
committerHisham Muhammad <hisham@gobolinux.org>2008-03-05 09:46:47 +0000
commit4df76d127b9cf830a15244da75976efb43752c6b (patch)
tree79074341a3cd73003186d0290ecad71cb9bed623 /configure.ac
parent5ed2b85c847995da3f4dc01c4d2790358adeb03d (diff)
Embed PLPA (Portable Linux Processor Affinity) in order to support
conflicting affinity API of different Linux kernel versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2e3a581c..f54310fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,11 @@ AC_CONFIG_HEADER([config.h])
# Checks for programs.
AC_PROG_CC
+AM_PROG_CC_C_O
+
+AM_DISABLE_SHARED
+AM_ENABLE_STATIC
+AC_PROG_LIBTOOL
# Checks for libraries.
AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
@@ -43,11 +48,13 @@ AC_TYPE_SIGNAL
AC_FUNC_STAT
AC_CHECK_FUNCS([memmove strncasecmp strstr strdup])
+save_cflags="${CFLAGS}"
CFLAGS="${CFLAGS} -std=c99"
AC_MSG_CHECKING([whether gcc -std=c99 option works])
AC_TRY_COMPILE(AC_INCLUDES_DEFAULT, [char *a; a = strdup("foo"); int i = 0; i++; // C99],
AC_MSG_RESULT([yes]),
AC_MSG_ERROR([htop is written in C99. A newer version of gcc is required.]))
+CFLAGS="$save_cflags"
PROCDIR=/proc
AC_ARG_WITH(proc, [ --with-proc=DIR Location of a Linux-compatible proc filesystem (default=/proc).],
@@ -66,5 +73,11 @@ fi
AC_CHECK_FILE($PROCDIR/stat,,AC_MSG_ERROR(Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
AC_CHECK_FILE($PROCDIR/meminfo,,AC_MSG_ERROR(Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
+PLPA_INCLUDED(plpa-1.1)
+PLPA_INIT(plpa_happy=yes, plpa_happy=no)
+if test "x$plpa_happy" = xno; then
+ AC_MSG_ERROR([Failed to initialize PLPA.])
+fi
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT

© 2014-2024 Faster IT GmbH | imprint | privacy policy