summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSahil Siddiq <icegambit91@gmail.com>2023-02-07 22:56:57 +0530
committerBenBE <BenBE@geshi.org>2023-05-22 12:07:16 +0200
commit3fc286257d3f40733d73722a0ea6b2ad1fd1a550 (patch)
tree494fa12d41aed8b6823209c467fabe2413e376f9 /configure.ac
parentf77ea80b8c6aa65329a66b9bcf3d1fa665fe01cd (diff)
Changes in configuration to identify location of 'term.h'
* ProvideTerm.h: New file * Update configure.ac to detect term.h * Update iwyu/htop.imp * Add ProvideTerm.h to Makefile Co-authored-by: BenBE <BenBE@geshi.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 36f25b22..a3cc572f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -360,6 +360,11 @@ if test "x$enable_unicode" = xyes; then
[AC_CHECK_HEADERS([ncurses.h], [],
[AC_MSG_ERROR([can not find required ncurses header file])])])])])
+ AC_CHECK_HEADERS([ncursesw/term.h], [],
+ [AC_CHECK_HEADERS([ncurses/term.h], [],
+ [AC_CHECK_HEADERS([term.h], [],
+ [AC_MSG_ERROR([can not find required term header file])])])])
+
# check if additional linker flags are needed for keypad(3)
# (at this point we already link against a working ncurses library with wide character support)
AC_SEARCH_LIBS([keypad], [tinfow tinfo])
@@ -375,13 +380,18 @@ else
AC_CHECK_HEADERS([curses.h], [],
[AC_CHECK_HEADERS([ncurses/curses.h], [],
[AC_CHECK_HEADERS([ncurses/ncurses.h], [],
- [AC_CHECK_HEADERS([ncurses.h] ,[],
+ [AC_CHECK_HEADERS([ncurses.h], [],
[AC_MSG_ERROR([can not find required ncurses header file])])])])])
+ AC_CHECK_HEADERS([ncurses/term.h], [],
+ [AC_CHECK_HEADERS([term.h], [],
+ [AC_MSG_ERROR([can not find required term header file])])])
+
# check if additional linker flags are needed for keypad(3)
# (at this point we already link against a working ncurses library)
AC_SEARCH_LIBS([keypad], [tinfo])
fi
+
if test "$enable_static" = yes; then
AC_SEARCH_LIBS([Gpm_GetEvent], [gpm])
fi

© 2014-2024 Faster IT GmbH | imprint | privacy policy