aboutsummaryrefslogtreecommitdiffstats
path: root/english/template/debian/installer.wml
diff options
context:
space:
mode:
authorFrank Lichtenheld <djpig>2005-06-02 16:30:44 +0000
committerFrank Lichtenheld <djpig>2005-06-02 16:30:44 +0000
commit91333a71c4df21218ea08580c798e958ef407060 (patch)
tree35d8310b90b687ced02b4956bf9357311b3e8924 /english/template/debian/installer.wml
parent1f40a409803dc74d8abc9667cd759cf74f967bc1 (diff)
Generate the list of images seperatly from the rest of the installer page
This makes changes to locations and list of architectures easier for the installer team and causes less work for the translators. The main code is in template/debian/installer.wml to make it easier to use this for other locations, too (like releases/*/debian-installer/) The URLs are defined in images.data. Maybe the most common URL can also be defined in installer.wml, but that has to be seen. CVS version numbers english/devel/debian-installer/Makefile: 1.4 -> 1.5 english/devel/debian-installer/images.data: INITIAL -> 1.1 english/devel/debian-installer/index.wml: 1.148 -> 1.149 english/template/debian/installer.wml: INITIAL -> 1.1
Diffstat (limited to 'english/template/debian/installer.wml')
-rw-r--r--english/template/debian/installer.wml33
1 files changed, 33 insertions, 0 deletions
diff --git a/english/template/debian/installer.wml b/english/template/debian/installer.wml
new file mode 100644
index 00000000000..cd58d7781bb
--- /dev/null
+++ b/english/template/debian/installer.wml
@@ -0,0 +1,33 @@
+<define-tag stable-images-arches>alpha\narm\nhppa\ni386\nia64\nm68k\nmips\nmipsel\npowerpc\nsparc\ns390</define-tag>
+
+<define-tag devel-images-arches><stable-images-arches /></define-tag>
+
+<define-tag strip-arches whitespace=delete>
+
+<set-var strip="%1" />
+<set-var arch="%0" />
+<subst-in-var strip " " "\n" />
+
+<foreach s strip>
+<subst-in-var arch "\n<get-var s />(\n|$)" "" reflags="s" >
+</foreach>
+<get-var arch />
+
+</define-tag>
+
+<define-tag images-list whitespace=delete>
+<preserve url arch format />
+<set-var %attributes />
+
+<when <not <get-var format />/>>
+<set-var format="[<a href="<get-var url />">@ARCH@</a>]" />
+</when>
+<when <not <get-var arch />/>>
+<set-var arch="<stable-images-arches/>" />
+</when>
+<subst-in-var arch " " "\n" />
+
+<foreach a arch><subst-in-string "<get-var format />" "@ARCH@" "<get-var a />"> </foreach>
+
+<restore url arch format />
+</define-tag>

© 2014-2024 Faster IT GmbH | imprint | privacy policy