aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Lange <DLange@git.local>2016-04-11 13:00:27 +0200
committerDaniel Lange <DLange@git.local>2016-04-11 13:00:27 +0200
commit283707c5e5bc436b78ea23bf5500cb6b16a01148 (patch)
treeb977131bbbb4c3bd8ade370aab2e4fc913440c04 /configure.ac
parentbea9b4798717b6f4e31085506dfc179eeb8dc17c (diff)
downloaddebian_htop-283707c5e5bc436b78ea23bf5500cb6b16a01148.tar.gz
debian_htop-283707c5e5bc436b78ea23bf5500cb6b16a01148.tar.bz2
debian_htop-283707c5e5bc436b78ea23bf5500cb6b16a01148.zip
Imported Upstream version 0.9upstream/0.9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 24 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 59ca6e0..ba95b19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,26 +2,23 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.57)
-AC_INIT([htop],[0.8.3],[loderunner@users.sourceforge.net])
+AC_INIT([htop],[0.9],[loderunner@users.sourceforge.net])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([htop.c])
AC_CONFIG_HEADER([config.h])
+AC_CONFIG_MACRO_DIR([m4])
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
-AM_DISABLE_SHARED
-AM_ENABLE_STATIC
+AC_DISABLE_SHARED
+AC_ENABLE_STATIC
AC_PROG_LIBTOOL
# Checks for libraries.
AC_CHECK_LIB([m], [ceil], [], [missing_libraries="$missing_libraries libm"])
-if test ! -z "$missing_libraries"; then
- AC_MSG_ERROR([missing libraries: $missing_libraries])
-fi
-
# Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
@@ -29,10 +26,6 @@ AC_CHECK_HEADERS([stdlib.h string.h strings.h sys/param.h sys/time.h unistd.h cu
missing_headers="$missing_headers $ac_header"
])
-if test ! -z "$missing_headers"; then
- AC_MSG_ERROR([missing headers: $missing_headers])
-fi
-
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL
AC_C_CONST
@@ -69,6 +62,11 @@ if test "x$enable_openvz" = xyes; then
AC_DEFINE(HAVE_OPENVZ, 1, [Define if openvz support enabled.])
fi
+AC_ARG_ENABLE(cgroup, [AC_HELP_STRING([--enable-cgroup], [enable cgroups support])], ,enable_cgroup="no")
+if test "x$enable_cgroup" = xyes; then
+ AC_DEFINE(HAVE_CGROUP, 1, [Define if cgroup support enabled.])
+fi
+
AC_ARG_ENABLE(vserver, [AC_HELP_STRING([--enable-vserver], [enable VServer support])], ,enable_vserver="no")
if test "x$enable_vserver" = xyes; then
AC_DEFINE(HAVE_VSERVER, 1, [Define if vserver support enabled.])
@@ -94,13 +92,24 @@ else
AC_CHECK_HEADERS([curses.h],[:],[missing_headers="$missing_headers $ac_header"])
fi
+if test ! -z "$missing_libraries"; then
+ AC_MSG_ERROR([missing libraries: $missing_libraries])
+fi
+if test ! -z "$missing_headers"; then
+ AC_MSG_ERROR([missing headers: $missing_headers])
+fi
+
+
+
AC_CHECK_FILE($PROCDIR/stat,,AC_MSG_ERROR(Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
AC_CHECK_FILE($PROCDIR/meminfo,,AC_MSG_ERROR(Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help.))
-PLPA_INCLUDED(plpa-1.1)
-PLPA_INIT(plpa_happy=yes, plpa_happy=no)
-AM_CONDITIONAL([HAVE_PLPA], [test "$plpa_happy" = "yes"])
-if test "$plpa_happy" = "yes"; then
+AC_ARG_ENABLE(plpa, [AC_HELP_STRING([--enable-plpa], [enable PLPA support for CPU affinity])], ,enable_plpa="yes")
+PLPA_INCLUDED
+PLPA_INIT([plpa-1.3.2], [plpa_happy=yes], [plpa_happy=no])
+AM_CONDITIONAL([HAVE_PLPA], [test "$plpa_happy" = "yes" && test "$enable_plpa" = "yes"])
+if test "$plpa_happy" = "yes" && test "$enable_plpa" = "yes"
+then
AC_DEFINE([HAVE_PLPA], [1], [Have plpa])
fi

© 2014-2024 Faster IT GmbH | imprint | privacy policy