aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastien Delafond <seb>2016-07-19 09:55:25 +0000
committerSebastien Delafond <seb>2016-07-19 09:55:25 +0000
commit6eeca2ae0a8b655686a456fe8ffcb69037d1bbf1 (patch)
tree109a022a5e3183f5d5cf77795735ef3a23fa9b3b
parentd5a2b752ea2bd498e0a2dde246506ea635a2087a (diff)
Correct Makefile with call to new script, and new arguments
CVS version numbers english/security/oval/Makefile: 1.12 -> 1.13
-rw-r--r--english/security/oval/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/english/security/oval/Makefile b/english/security/oval/Makefile
index 79d2fd733de..22d3f089ce7 100644
--- a/english/security/oval/Makefile
+++ b/english/security/oval/Makefile
@@ -18,12 +18,14 @@ all:: check_empty_files $(XMLFILES)
install:: $(XMLDESTFILES)
-oval-definitions-%.xml: parseDsa2Oval.py \
+oval-definitions-%.xml: generate.py \
$(wildcard oval/*/*.py) \
$(wildcard $(ENGLISHDIR)/security/%/dsa-*.wml) \
- $(wildcard $(ENGLISHDIR)/security/%/dsa-*.data)
+ $(wildcard $(ENGLISHDIR)/security/%/dla-*.wml) \
+ $(wildcard $(ENGLISHDIR)/security/%/dsa-*.data) \
+ $(wildcard $(ENGLISHDIR)/security/%/dla-*.data)
@[ -e $(PYTHON) ] || { echo "ERROR: Required python binary $(PYTHON) is not available, aborting generation" >&2; exit 1; }
- -$(PYTHON) parseDsa2Oval.py -d ../$(patsubst oval-definitions-%.xml,%,$@) >$@
+ -$(PYTHON) generate.py -d .. -y $(patsubst oval-definitions-%.xml,%,$@) >$@
# Warn if empty files are generated
# Note: They cannot be removed or the install target will fail later
@[ -s $@ ] || echo "WARNING: OVAL Definition $@ is empty, please review script and/or DSAs"

© 2014-2024 Faster IT GmbH | imprint | privacy policy