aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaura Arjona Reina <larjona@debian.org>2020-12-27 17:35:29 +0100
committerLaura Arjona Reina <larjona@debian.org>2020-12-27 17:36:27 +0100
commitd46c65ade631cdbcbc0f2d6445a7a455d4c26e32 (patch)
tree4ef637607319688fca915206cfc27fdaf0da5104
parent027f0af6e3820ddc03ba11e84ac7b0375d95f142 (diff)
Add recipe for building index.wml, so it's updated when a new security advisory is published
-rw-r--r--english/intro/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/english/intro/Makefile b/english/intro/Makefile
index de9aebfb229..da871431606 100644
--- a/english/intro/Makefile
+++ b/english/intro/Makefile
@@ -9,6 +9,25 @@ include $(WMLBASE)/Make.lang
about.$(LANGUAGE).html: $(TEMPLDIR)/release_info.wml
+ifndef SUBLANG
+INDEXPAGE := index.$(LANGUAGE).html
+else
+INDEXPAGE := $(sort $(foreach i,$(SUBLANG),$(subst index,index.$(LANGUAGE)-$(i),index.html)))
+endif
+
+$(INDEXPAGE): index.wml $(wildcard $(ENGLISHSRCDIR)/security/$(CUR_YEAR)/dsa-[0-9]*.wml) \
+ $(TEMPLDIR)/recent_list.wml $(GETTEXTDEP)
+
+ifeq "$(LANGUAGE)" "zh"
+ @echo -n "Processing $(<F): "
+ $(shell echo $(WML) | perl -pe 's,:.zh-(..)\.html,:index.zh-$$1.html,g') \
+ $(shell egrep '^-D (CUR_|CHAR)' ../.wmlrc) \
+ $(<F)
+ @$(GENERATE_ZH_VARIANTS) index html
+else
+ $(WML) $(<F)
+endif
+
organization.$(LANGUAGE).html: organization.wml \
$(ENGLISHSRCDIR)/intro/organization.data \
$(ENGLISHDIR)/MailingLists/lists.cfg \

© 2014-2024 Faster IT GmbH | imprint | privacy policy