summaryrefslogtreecommitdiffstats
path: root/lib
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2023-02-03 18:42:29 +0100
committerSalvatore Bonaccorso <carnil@debian.org>2023-02-04 11:26:51 +0100
commitcc99c2fc7fb2b2888e1d1bb3bedb2f978b0e36b0 (patch)
treedc45c088d37db0845dc9fe4aa46600a408b10107 /lib
parent108028de7bf8b44be5970ca10e9f97ed9e2e4658 (diff)
lib/debian-releases.mk: Add support for fetching from different archive areas
For suites older than bookworm, fix section to main, contrib and non-free. Starting in bookworm an additonal archive section non-free-firmware will be present. Link: https://bugs.debian.org/1030321 Signed-off-by: Salvatore Bonaccorso <carnil@debian.org>
Diffstat (limited to 'lib')
-rw-r--r--lib/debian-releases.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/debian-releases.mk b/lib/debian-releases.mk
index eb03a874da..f8ae1fb34d 100644
--- a/lib/debian-releases.mk
+++ b/lib/debian-releases.mk
@@ -15,6 +15,11 @@ $(1)_MIRROR = $$(MIRROR)
$(1)_DIST = $(1)
$(1)_ARCHS = $(call get_config, '.distributions.$(1).architectures[]')
$(1)_RELEASE = $(1)
+ifneq (,$(filter jessie stretch buster bullseye,$(1)))
+$(1)_SECTIONS = main contrib non-free
+else
+$(1)_SECTIONS = main contrib non-free non-free-firmware
+endif
$(1)_SUBRELEASE =
RELEASES += $(1)
endef
@@ -34,6 +39,7 @@ $(1)_security_DIST = $(1)-security
endif
$(1)_security_ARCHS = $$($(1)_ARCHS)
$(1)_security_RELEASE = $(1)
+$(1)_security_SECTIONS = $$($(1)_SECTIONS)
$(1)_security_SUBRELEASE = security
RELEASES += $(1)_security
endef
@@ -45,6 +51,7 @@ $(1)_backports_MIRROR = $$(MIRROR)
$(1)_backports_DIST = $(1)-backports
$(1)_backports_ARCHS = $$($(1)_ARCHS)
$(1)_backports_RELEASE = $(1)-backports
+$(1)_backports_SECTIONS = $$($(1)_SECTIONS)
$(1)_backports_SUBRELEASE =
RELEASES += $(1)_backports
endef

© 2014-2024 Faster IT GmbH | imprint | privacy policy