aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDaniel Lange <DLange@git.local>2024-01-10 11:29:57 +0100
committerDaniel Lange <DLange@git.local>2024-01-10 11:37:17 +0100
commit6f1693f38645797b063b4fc570191dad87bf78d5 (patch)
tree8d9ecc35f338f41f6453f6bca0c595ab7fa9b022 /debian
parent96e043e662eaa36143b75faa30e8c3ffcae6a615 (diff)
downloaddebian_htop-6f1693f38645797b063b4fc570191dad87bf78d5.tar.gz
debian_htop-6f1693f38645797b063b4fc570191dad87bf78d5.tar.bz2
debian_htop-6f1693f38645797b063b4fc570191dad87bf78d5.zip
Release 3.3.0-1debian/3.3.0-1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog50
-rw-r--r--debian/control2
-rw-r--r--debian/copyright4
-rw-r--r--debian/patches/001_remove_lxc_special_handling.patch70
-rw-r--r--debian/patches/series1
5 files changed, 53 insertions, 74 deletions
diff --git a/debian/changelog b/debian/changelog
index 5e05ba9..6a18a69 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,53 @@
+htop (3.3.0-1) unstable; urgency=medium
+
+ * Import upstream 3.3.0 release
+ * Drop Debian patch (Remove LXC special handling for CPUs)
+ * Multiple refactorings and code improvements
+ * Shorten docker container IDs to 12 characters
+ * Settings: preserve empty header
+ * Fix execlp() argument without pointer cast
+ * OpenFilesScreen: Make column sizing dynamic for file size, offset and inode
+ * HeaderLayout: add "3 columns - 40/30/30", "... 30/40/30" & "... 30/30/40"
+ * Meter: use correct unicode characters for digit '9'
+ * Note in manual re default memory units of KiB
+ * Add column for process container name
+ * Add logic to filter the container name (+type) from the CGroup name
+ * Change NetworkIOMeter value unit from KiB/s to bytes/second
+ * Cap DiskIOMeter "utilisation" percentage at 100%
+ * Shorten podman/libpod container IDs to 12 characters
+ * Write configuration to temporary file first
+ * Incorporate shared memory in bar text
+ * Move shared memory next to used memory
+ * Correct order of memory meter in help
+ * Add recalculate to Ctrl-L refresh
+ * Update process list on thread visibility toggling
+ * Support dynamic screens with 'top-most' entities beyond processes
+ * Introduce Row and Table classes for screens beyond top-processes
+ * Rework ZramMeter and remove MeterClass.comprisedValues
+ * More robust logic for CPU process percentages
+ * Show year as start time for processes older than a year
+ * Short-term fix for docker container detection
+ * default color preset: use bold blue for better visibility
+ * Document 'O' keyboard shortcut
+ * Implement logic for '--max-iterations'
+ * Update F5 key label on tab switch (Tree <-> List)
+ * Force re-sorting of the process list view after switching between list/treeview mode
+ * Linux: (hack) work around the fact that Zswapped pages may be SwapCached
+ * Linux: implement zswap support
+ * {Memory,Swap}Meter: add "compressed memory" metrics
+ * Fix scroll relative to followed process
+ * ZramMeter: update bar mode
+ * Increase Search and Filter max string length to 128
+ * Improve CPU computation code
+ * Remove LXC special handling for the CPU count
+ * Create new File Descriptor meter
+ * Linux: add IRQ PSI meter
+ * Linux: highlight username if process has elevated privileges
+ * Add support for scheduling policies
+ * Add a systemd user meter to monitor user units.
+
+ -- Daniel Lange <DLange@debian.org> Wed, 10 Jan 2024 11:30:00 +0100
+
htop (3.2.2-2) unstable; urgency=medium
* Remove LXC special handling for CPUs
diff --git a/debian/control b/debian/control
index b6e2210..7091001 100644
--- a/debian/control
+++ b/debian/control
@@ -15,7 +15,7 @@ Build-Depends: debhelper-compat (= 13),
libnl-genl-3-dev [linux-any],
libsensors-dev [!hurd-any],
pkg-config
-Standards-Version: 4.6.1
+Standards-Version: 4.6.2
Rules-Requires-Root: no
Homepage: https://htop.dev/
Vcs-Browser: https://salsa.debian.org/debian/htop
diff --git a/debian/copyright b/debian/copyright
index 5f0f579..f17b2d8 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -6,11 +6,11 @@ Source: https://github.com/htop-dev/htop/releases
Files: *
License: GPL-2+
Copyright: 2004-2019 Hisham Muhammad
- 2020-2023 htop dev team
+ 2020-2024 htop dev team
Files: debian/*
License: GPL-2+
-Copyright: 2016-2023 Daniel Lange
+Copyright: 2016-2024 Daniel Lange
2018-2021 Graham Inggs
2008-2016 Eugene V. Lyubimkin
2004-2008 Bartosz Fenski
diff --git a/debian/patches/001_remove_lxc_special_handling.patch b/debian/patches/001_remove_lxc_special_handling.patch
deleted file mode 100644
index 40b6077..0000000
--- a/debian/patches/001_remove_lxc_special_handling.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-commit 11318b5ef6de6b2f80186a888cd5477e0ff167bb
-Author: Daniel Lange <DLange@git.local>
-Date: Sat Feb 25 14:12:45 2023 +0100
-
- Remove LXC special handling for the CPU count
-
- LXC shows the real host CPU ids but can be limited in configuration
- as to which cores are used. Still the sysfs files are visible and the
- CPUs (stay) marked online. We will need to parse
- /sys/devices/system/cpu/online to follow LXC's logic.
- Revert for now until we can come up with a better handling of the LXC hacks.
-
- Cf. issue #1195
- Essentially reverting 33973f7e and 0d53245c (#993, #995)
-
-Index: debian_htop/linux/LinuxProcessList.c
-===================================================================
---- debian_htop.orig/linux/LinuxProcessList.c
-+++ debian_htop/linux/LinuxProcessList.c
-@@ -167,28 +167,6 @@ static void LinuxProcessList_initNetlink
-
- #endif
-
--static unsigned int scanAvailableCPUsFromCPUinfo(LinuxProcessList* this) {
-- FILE* file = fopen(PROCCPUINFOFILE, "r");
-- if (file == NULL)
-- return this->super.existingCPUs;
--
-- unsigned int availableCPUs = 0;
--
-- while (!feof(file)) {
-- char buffer[PROC_LINE_LENGTH];
--
-- if (fgets(buffer, PROC_LINE_LENGTH, file) == NULL)
-- break;
--
-- if (String_startsWith(buffer, "processor"))
-- availableCPUs++;
-- }
--
-- fclose(file);
--
-- return availableCPUs ? availableCPUs : 1;
--}
--
- static void LinuxProcessList_updateCPUcount(ProcessList* super) {
- /* Similar to get_nprocs_conf(3) / _SC_NPROCESSORS_CONF
- * https://sourceware.org/git/?p=glibc.git;a=blob;f=sysdeps/unix/sysv/linux/getsysstats.c;hb=HEAD
-@@ -263,12 +241,6 @@ static void LinuxProcessList_updateCPUco
- if (existing < 1)
- return;
-
-- if (Running_containerized) {
-- /* LXC munges /proc/cpuinfo but not the /sys/devices/system/cpu/ files,
-- * so limit the visible CPUs to what the guest has been configured to see: */
-- currExisting = active = scanAvailableCPUsFromCPUinfo(this);
-- }
--
- #ifdef HAVE_SENSORS_SENSORS_H
- /* When started with offline CPUs, libsensors does not monitor those,
- * even when they become online. */
-@@ -277,7 +249,7 @@ static void LinuxProcessList_updateCPUco
- #endif
-
- super->activeCPUs = active;
-- assert(Running_containerized || (existing == currExisting));
-+ assert(existing == currExisting);
- super->existingCPUs = currExisting;
- }
-
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 4fd518f..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-001_remove_lxc_special_handling.patch

© 2014-2024 Faster IT GmbH | imprint | privacy policy