aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorEugene V. Lyubimkin <jackyf.devel@gmail.com>2008-11-16 20:36:18 +0200
committerDaniel Lange <DLange@git.local>2016-04-11 13:00:23 +0200
commitbcb965d78ae0b4599fe77a2d641b3ff035658fc9 (patch)
tree59066e7fa5473b02eefaea37ac015cfaea7cd7c6 /debian/rules
parent2eabf3432b05b93ce4de9af283ae549d0f7c18c8 (diff)
parentc74c38760df69bb87e93dff18cf91464e5d02f37 (diff)
downloaddebian_htop-bcb965d78ae0b4599fe77a2d641b3ff035658fc9.tar.gz
debian_htop-bcb965d78ae0b4599fe77a2d641b3ff035658fc9.tar.bz2
debian_htop-bcb965d78ae0b4599fe77a2d641b3ff035658fc9.zip
Imported Debian patch 0.8.1-1debian/0.8.1-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules69
1 files changed, 19 insertions, 50 deletions
diff --git a/debian/rules b/debian/rules
index 946e774..ee08817 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,78 +1,47 @@
#!/usr/bin/make -f
-# rules file for htop (May 2004)
-# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+include /usr/share/quilt/quilt.make
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-config.status: configure
+config.status: configure $(QUILT_STAMPFN)
dh_testdir
-
cp /usr/share/misc/config.sub /usr/share/misc/config.guess .
-
- CFLAGS="$(CFLAGS)" LDFLAGS="$(INSTALL_PROGRAM)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
+ CFLAGS="$(CFLAGS)" LDFLAGS="$(INSTALL_PROGRAM)" ./configure \
+ --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
+ --prefix=/usr --mandir=\$${prefix}/share/man \
+ --infodir=\$${prefix}/share/info \
+ --enable-taskstats --enable-unicode --enable-openvz
build: build-stamp
-
-build-stamp: config.status
- dh_testdir
-
- $(MAKE)
-
+build-stamp: config.status
+ dh build --before dh_auto_configure
+ dh build --after dh_auto_configure
touch build-stamp
-clean:
+clean: unpatch
dh_testdir
dh_testroot
rm -f build-stamp
-
- -$(MAKE) distclean
-
+
+ ([ -f Makefile ] && $(MAKE) distclean) || true
+
dh_clean config.sub config.guess
dh_clean
install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
+ dh install --before dh_auto_install
$(MAKE) install DESTDIR=$(CURDIR)/debian/htop
+ dh install --after dh_auto_install
-binary-indep: build install
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installmenu
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+binary-indep:
+binary-arch: install
+ dh binary-arch
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install

© 2014-2024 Faster IT GmbH | imprint | privacy policy