summaryrefslogtreecommitdiffstats
path: root/BatteryMeter.c
Commit message (Collapse)AuthorAgeFilesLines
* Axe automated header generation.Zev Weiss2020-09-031-9/+0
| | | | | | | | | | | | | | Reasoning: - implementation was unsound -- broke down when I added a fairly basic macro definition expanding to a struct initializer in a *.c file. - made it way too easy (e.g. via otherwise totally innocuous git commands) to end up with timestamps such that it always ran MakeHeader.py but never used its output, leading to overbuild noise when running what should be a null 'make'. - but mostly: it's just an awkward way of dealing with C code.
* Clean up existing whitespaceDaniel Flanagan2019-10-311-1/+1
|
* Security review: check results of snprintf.Hisham Muhammad2017-07-271-4/+4
| | | | | Calls marked with xSnprintf shouldn't fail. Abort program cleanly if any of them does.
* Rename Meter.setValues() functions to updateValues()Explorer092016-05-041-2/+2
| | | | | | | | | | | | Rationale (copied from htop issue #471): The function name "setValues" is misleading. For most OOP (object- oriented programming) contexts, setXXX functions mean they will change some member variables of an object into something specified in function arguments. But in the *Meter_setValues() case, the new values are not from the arguments, but from a hard-coded source. The caller is not supposed to change the values[] to anything it likes, but rather to "update" the values from the source. Hence, updateValues is a better name for this family of functions.
* Explicit "maxItems" property of metersExplorer092016-03-111-0/+1
| | | | | | | | | Two changes in this commit: - All meters now explicitly specify "maxItems" property, even for just 1 item. (Exception is "container" CPU meter classes, which use CUSTOM_METERMODE.) - "maxItems" being 0 is now allowed. This will let bar meters and graph meters render an empty meter.
* Rename String to StringUtils.David Hunt2015-08-191-1/+1
| | | | | | | | | Fixes building on case-insensitive filesystems where String.h gets confused with <string.h>. From d734dacea0a10d0465dad4e95b3421511e7da112 Mon Sep 17 00:00:00 2001 From: David Hunt <dhunt@iolanthe.attlocal.net> Date: Sat, 11 Jul 2015 20:56:31 -0500 Subject: [PATCH 1/8] Rename String to StringUtils
* Merge branch 'master' into wipHisham Muhammad2015-03-161-0/+1
|\ | | | | | | | | | | | | | | | | | | | | Conflicts: Process.c Process.h linux/LinuxProcess.c linux/LinuxProcess.h linux/LinuxProcessList.c unsupported/Platform.c unsupported/Platform.h
| * Fix allocation of processes. Closes #166.Hisham Muhammad2015-02-231-0/+1
| | | | | | | | | | | | | | | | | | Conflicts: Process.c Process.h ProcessList.c ScreenManager.c linux/LinuxProcessList.c
* | Another mega-patch for the refactoring process.Hisham Muhammad2015-01-231-2/+2
|/ | | | | Kinda runs, but functionality from the original main loop is still missing. Patience.
* Move platform-dependent parts of Linux battery meter.Hisham Muhammad2014-11-271-266/+12
|
* More sanity checks.Hisham Muhammad2014-04-241-2/+3
|
* Make static analyzers happy.Hisham Muhammad2014-04-241-8/+8
|
* Oops, fix use of memset.Hisham Muhammad2014-04-241-1/+1
|
* Fix array limit.Hisham Muhammad2014-04-241-3/+4
|
* Remove useless test.Hisham Muhammad2014-04-241-2/+1
|
* Refactor and fix resource leaks.Hisham Muhammad2014-04-221-127/+119
|
* BUGFIX: Fix crash when adding meters and toggling detailed CPU time.Hisham Muhammad2014-01-161-1/+0
| | | | | See https://bugzilla.redhat.com/show_bug.cgi?id=987805 for details. (thanks to Dawid Gajownik for the detailed analysis!)
* Changes in object model: separate class objects to store vtable. Also, nicer ↵Hisham Muhammad2012-12-051-3/+6
| | | | UTF-8 display of big numbers.
* minor style cleanupsHisham Muhammad2012-02-021-24/+9
|
* Remove old memory debugging routines. We have Valgrind nowadays.Hisham Muhammad2011-12-261-1/+0
|
* major header cleanupHisham Muhammad2011-12-261-6/+12
|
* cleanups and fixes, thanks to cppcheck and gcc -WextraHisham Muhammad2011-10-251-2/+5
|
* Tempus fugit.Hisham Muhammad2011-05-261-1/+1
|
* Improve battery meter support (thanks to Richard W.) Closes #3063541.Hisham Muhammad2010-11-201-3/+22
|
* Tempus fugit.Hisham Muhammad2010-02-251-1/+1
|
* warning fixesHisham Muhammad2010-02-251-5/+5
|
* minor tweaks by David WeberHisham Muhammad2010-02-221-3/+1
|
* don't use unbounded operationsHisham Muhammad2009-06-021-4/+4
|
* updated battery meter code from Ian Hands, slightly tweakedHisham Muhammad2009-04-271-57/+247
|
* ACPI Battery meterHisham Muhammad2008-09-231-0/+141
contributed by Ian Hands

© 2014-2024 Faster IT GmbH | imprint | privacy policy