summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorfraggerfox <santhosh.raju@gmail.com>2021-03-15 13:14:39 +0530
committerBenBE <BenBE@geshi.org>2021-06-26 12:18:37 +0200
commit4b49de44a8659674c6e92ba70e0c1930b2b9315b (patch)
treed831fd16f5a13843766d9ae18a0060ff1b3d5b39 /configure.ac
parent30dc4a28125e7199a51abde86af7b73027fa0bd2 (diff)
Add NetBSD platform support without procfs dependency
- TODO, clean up the code base and update comments in code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cd6da57d..ec2222d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,10 @@ freebsd*|kfreebsd*)
my_htop_platform=freebsd
AC_DEFINE([HTOP_FREEBSD], [], [Building for FreeBSD.])
;;
+netbsd*)
+ my_htop_platform=netbsd
+ AC_DEFINE([HTOP_NETBSD], [], [Building for NetBSD.])
+ ;;
openbsd*)
my_htop_platform=openbsd
AC_DEFINE([HTOP_OPENBSD], [], [Building for OpenBSD.])
@@ -196,6 +200,10 @@ if test "$my_htop_platform" = linux; then
fi
fi
+if test "$my_htop_platform" = netbsd; then
+ AC_SEARCH_LIBS([kvm_open], [kvm], [], [AC_MSG_ERROR([can not find required function kvm_open()])])
+fi
+
if test "$my_htop_platform" = openbsd; then
AC_SEARCH_LIBS([kvm_open], [kvm], [], [AC_MSG_ERROR([can not find required function kvm_open()])])
fi
@@ -630,6 +638,7 @@ AC_DEFINE_UNQUOTED([COPYRIGHT], ["(C) 2004-2019 Hisham Muhammad. (C) 2020-2021 h
AM_CONDITIONAL([HTOP_LINUX], [test "$my_htop_platform" = linux])
AM_CONDITIONAL([HTOP_FREEBSD], [test "$my_htop_platform" = freebsd])
AM_CONDITIONAL([HTOP_DRAGONFLYBSD], [test "$my_htop_platform" = dragonflybsd])
+AM_CONDITIONAL([HTOP_NETBSD], [test "$my_htop_platform" = netbsd])
AM_CONDITIONAL([HTOP_OPENBSD], [test "$my_htop_platform" = openbsd])
AM_CONDITIONAL([HTOP_DARWIN], [test "$my_htop_platform" = darwin])
AM_CONDITIONAL([HTOP_SOLARIS], [test "$my_htop_platform" = solaris])

© 2014-2024 Faster IT GmbH | imprint | privacy policy