summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Lange <DLange@git.local>2020-11-17 11:05:15 +0100
committerDaniel Lange <DLange@git.local>2020-11-17 11:05:15 +0100
commitfec9af4e6fd7e45e4cb623a84c34b92d3e506b3f (patch)
treecfc8d5daea3c49a373c4d501f9b37a354fb94c94 /configure.ac
parenta94fd87b05aa23d453d6e238746b5a55e75544bd (diff)
parent1b225cd7a0af03a6349c48326118a287fc36acd0 (diff)
Merge branch 'temperature_v2' of cgzones/htop
Closes #111, closes #49 Closes #93 - thank you for leading the way @DX37 (Maxim Kurnosenko)!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f774c8ef..aed4947e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -308,6 +308,16 @@ then
])
fi
+AC_ARG_ENABLE(sensors, [AS_HELP_STRING([--enable-sensors], [enable libsensors support for reading temperature data.])],, enable_sensors="check")
+if test "x$enable_sensors" = xyes; then
+ AC_CHECK_LIB([sensors], [sensors_get_value], [], [missing_libraries="$missing_libraries libsensors"])
+ AC_CHECK_HEADERS([sensors/sensors.h], [], [missing_headers="$missing_headers $ac_header"])
+elif test "x$enable_sensors" = xcheck; then
+ enable_sensors=yes
+ AC_CHECK_LIB([sensors], [sensors_get_value], [], [enable_sensors=no])
+ AC_CHECK_HEADERS([sensors/sensors.h], [], [enable_sensors=no])
+fi
+
AM_CFLAGS="\
-Wall\
-Wcast-align\
@@ -386,6 +396,7 @@ AC_MSG_RESULT([
(Linux) taskstats: $enable_taskstats
(Linux) affinity: $enable_linux_affinity
(Linux) delay accounting: $enable_delayacct
+ (Linux) sensors: $enable_sensors
unicode: $enable_unicode
hwloc: $enable_hwloc
setuid: $enable_setuid

© 2014-2024 Faster IT GmbH | imprint | privacy policy