summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHisham Muhammad <hisham@gobolinux.org>2014-11-24 20:11:33 -0200
committerHisham Muhammad <hisham@gobolinux.org>2014-11-24 20:11:33 -0200
commita75161f8628d04a77bb85ff68a25aa0985b9e15d (patch)
tree614c894713b7dafbd69e1127767e125f6e84d964 /configure.ac
parentaaaaf063a17f420634632ec9f9fdd1bd48755c4e (diff)
Get Linux "emulation" working again for our FreeBSD folks using linprocfs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 45279181..bc586d99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,8 +32,6 @@ case "$target" in
my_htop_platform=unsupported
;;
esac
-AM_CONDITIONAL([HTOP_LINUX], [test "$my_htop_platform" = linux])
-AM_CONDITIONAL([HTOP_UNSUPPORTED], [test "$my_htop_platform" = unsupported])
# Checks for libraries.
# ----------------------------------------------------------------------
@@ -76,6 +74,8 @@ PROCDIR=/proc
AC_ARG_ENABLE(proc, [AC_HELP_STRING([--enable-proc], [use Linux-compatible proc filesystem])], enable_proc="yes", enable_proc="no")
if test "x$enable_proc" = xyes; then
+ # An enabled proc assumes we're emulating Linux.
+ my_htop_platform=linux
AC_DEFINE(HAVE_PROC, 1, [Define if using a Linux-compatible proc filesystem.])
fi
@@ -182,6 +182,8 @@ fi
# We're done, let's go!
# ----------------------------------------------------------------------
+AM_CONDITIONAL([HTOP_LINUX], [test "$my_htop_platform" = linux])
+AM_CONDITIONAL([HTOP_UNSUPPORTED], [test "$my_htop_platform" = unsupported])
AC_SUBST(my_htop_platform)
AC_CONFIG_FILES([Makefile htop.1])
AC_OUTPUT

© 2014-2024 Faster IT GmbH | imprint | privacy policy