summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiederik de Groot <ddegroot@talon.nl>2017-04-19 16:12:17 +0200
committerDiederik de Groot <ddegroot@talon.nl>2017-04-19 16:19:32 +0200
commitb258d6e53eb421651ac3fbe9c99e636f0f8cdfc4 (patch)
tree6bb60a13ca81815e2c74fbe7f65193949ff54e4b /configure.ac
parent5570748dd27e5b1e8c109b80fb31500fcd8f7fad (diff)
Initial addition of dragonflybsd (based on FreeBSD)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 14 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index eb055b56..90b0e850 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@ AM_PROG_CC_C_O
# Required by hwloc scripts
AC_USE_SYSTEM_EXTENSIONS
-LT_INIT([disable-shared static])
+#LT_INIT([disable-shared static])
# Checks for platform.
# ----------------------------------------------------------------------
@@ -40,6 +40,9 @@ freebsd*|kfreebsd*)
openbsd*)
my_htop_platform=openbsd
;;
+dragonfly*)
+ my_htop_platform=dragonflybsd
+ ;;
darwin*)
my_htop_platform=darwin
;;
@@ -186,14 +189,15 @@ m4_define([HTOP_CHECK_LIB],
AC_ARG_ENABLE(unicode, [AS_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes")
if test "x$enable_unicode" = xyes; then
HTOP_CHECK_SCRIPT([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW], "ncursesw6-config",
- HTOP_CHECK_SCRIPT([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], "ncursesw5-config",
- HTOP_CHECK_SCRIPT([ncurses], [addnwstr], [HAVE_LIBNCURSESW], "ncurses5-config",
- HTOP_CHECK_LIB([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW],
- HTOP_CHECK_LIB([ncursesw], [addnwstr], [HAVE_LIBNCURSESW],
- HTOP_CHECK_LIB([ncurses], [addnwstr], [HAVE_LIBNCURSESW],
- missing_libraries="$missing_libraries libncursesw"
- AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
- ))))))
+ HTOP_CHECK_SCRIPT([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], "ncursesw6-config",
+ HTOP_CHECK_SCRIPT([ncursesw], [addnwstr], [HAVE_LIBNCURSESW], "ncursesw5-config",
+ HTOP_CHECK_SCRIPT([ncurses], [addnwstr], [HAVE_LIBNCURSESW], "ncurses5-config",
+ HTOP_CHECK_LIB([ncursesw6], [addnwstr], [HAVE_LIBNCURSESW],
+ HTOP_CHECK_LIB([ncursesw], [addnwstr], [HAVE_LIBNCURSESW],
+ HTOP_CHECK_LIB([ncurses], [addnwstr], [HAVE_LIBNCURSESW],
+ missing_libraries="$missing_libraries libncursesw"
+ AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
+ )))))))
AC_CHECK_HEADERS([ncursesw/curses.h],[:],
[AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
@@ -264,6 +268,7 @@ AC_DEFINE_UNQUOTED(COPYRIGHT, "(C) 2004-$year Hisham Muhammad", [Copyright messa
# ----------------------------------------------------------------------
AM_CONDITIONAL([HTOP_LINUX], [test "$my_htop_platform" = linux])
AM_CONDITIONAL([HTOP_FREEBSD], [test "$my_htop_platform" = freebsd])
+AM_CONDITIONAL([HTOP_DRAGONFLYBSD], [test "$my_htop_platform" = dragonflybsd])
AM_CONDITIONAL([HTOP_OPENBSD], [test "$my_htop_platform" = openbsd])
AM_CONDITIONAL([HTOP_DARWIN], [test "$my_htop_platform" = darwin])
AM_CONDITIONAL([HTOP_UNSUPPORTED], [test "$my_htop_platform" = unsupported])

© 2014-2024 Faster IT GmbH | imprint | privacy policy