summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndré Carvalho <asantostc@gmail.com>2017-12-04 00:15:29 -0200
committerHisham Muhammad <hisham@gobolinux.org>2017-12-04 00:15:29 -0200
commitb7b66b76a5f01ac570d537d27a7e156af248d6f4 (patch)
tree66f8094a5fc284eb135538020b78b6287dc0df52 /configure.ac
parent52831955c759ecfa5d5f527bdf54f20545fdbcff (diff)
Adds support for linux delay accounting (#667)
Adds support for showing columns with linux delay accounting. This information can be read from the netlink interface, and thus we set up a socket to read from that when initializing the LinuxProcessList (LinuxProcessList_initNetlinkSocket). After that, for each process we call LinuxProcessList_readDelayAcctData, which sends a message thru the socket after setting up a callback to get the answer from the Kernel. That callback sets the process total delay time attribute. We then set the delay percent as the percentage of time process cpu time since last scan.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f8af8a96..4b266535 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,6 +256,17 @@ then
AC_DEFINE(HAVE_SETUID_ENABLED, 1, [Define if setuid support should be enabled.])
fi
+AC_ARG_ENABLE(delayacct, [AS_HELP_STRING([--enable-delayacct], [enable linux delay accounting])],, enable_delayacct="no")
+if test "x$enable_delayacct" = xyes
+then
+ PKG_CHECK_MODULES(LIBNL3, libnl-3.0, [], [missing_libraries="$missing_libraries libnl-3"])
+ PKG_CHECK_MODULES(LIBNL3GENL, libnl-genl-3.0, [], [missing_libraries="$missing_libraries libnl-genl-3"])
+ CFLAGS+=" $LIBNL3_CFLAGS $LIBNL3GENL_CFLAGS"
+ LIBS+=" $LIBNL3_LIBS $LIBNL3GENL_LIBS"
+ AC_DEFINE(HAVE_DELAYACCT, 1, [Define if delay accounting support should be enabled.])
+fi
+
+
# Bail out on errors.
# ----------------------------------------------------------------------
if test ! -z "$missing_libraries"; then

© 2014-2024 Faster IT GmbH | imprint | privacy policy