summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHisham Muhammad <hisham@gobolinux.org>2015-03-15 22:53:10 -0300
committerHisham Muhammad <hisham@gobolinux.org>2015-03-15 22:53:10 -0300
commitd2acffa59abba396b710f71436823c54bfcf2f7e (patch)
tree495599681c0cfd4288ade3f4b9482434a1988a6b /configure.ac
parentc29e53c5d5aa9b9a5e13ea5ee74bb0fd13fc7f93 (diff)
parent50000d808e23a80b8e3ec26b46062c419edff6d4 (diff)
Merge branch 'wip' of https://github.com/hishamhm/htop into freebsd
Conflicts: htop.c unsupported/Platform.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 328833d0..56608145 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,6 +4,8 @@
AC_PREREQ(2.65)
AC_INIT([htop],[1.0.3],[hisham@gobolinux.org])
+year=$(date +%Y)
+
# The following two lines are required by hwloc scripts
AC_USE_SYSTEM_EXTENSIONS
AC_CANONICAL_TARGET
@@ -71,6 +73,19 @@ AC_TRY_COMPILE(AC_INCLUDES_DEFAULT, [char *a; a = strdup("foo"); int i = 0; i++;
AC_MSG_ERROR([htop is written in C99. A newer version of gcc is required.]))
CFLAGS="$save_cflags"
+save_cflags="${CFLAGS}"
+CFLAGS="$CFLAGS -Wextra"
+AC_MSG_CHECKING([if compiler supports -Wextra])
+AC_TRY_COMPILE([], [], [
+ wextra_flag=-Wextra
+ AC_MSG_RESULT([yes])
+],[
+ wextra_flag=
+ AC_MSG_RESULT([no])
+])
+CFLAGS="$save_cflags"
+AC_SUBST(wextra_flag)
+
# Checks for features and flags.
# ----------------------------------------------------------------------
PROCDIR=/proc
@@ -187,6 +202,8 @@ if test ! -z "$missing_headers"; then
AC_MSG_ERROR([missing headers: $missing_headers])
fi
+AC_DEFINE_UNQUOTED(COPYRIGHT, "(C) 2004-$year Hisham Muhammad", [Copyright message.])
+
# We're done, let's go!
# ----------------------------------------------------------------------
AM_CONDITIONAL([HTOP_LINUX], [test "$my_htop_platform" = linux])

© 2014-2024 Faster IT GmbH | imprint | privacy policy