summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael McConville <mmcconville ~a~ mykolab ~d~ com>2015-09-18 00:46:48 -0400
committerMichael McConville <mmcconville ~a~ mykolab ~d~ com>2015-09-18 00:46:48 -0400
commita9a5a539cf59cb81d2a3da610b0d1ff56c1247cc (patch)
treeb7ae88ed9c6b4a23d1a3ae79450fb6ea266136e7 /configure.ac
parent445222e48c380bbb5d209a82f9614187bc751b41 (diff)
(Very) initial working OpenBSD port
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 13b09a6b..f865cbf2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,9 @@ case "$target" in
*freebsd*)
my_htop_platform=freebsd
;;
+*openbsd*)
+ my_htop_platform=openbsd
+ ;;
*darwin*)
my_htop_platform=darwin
;;
@@ -168,6 +171,10 @@ if test "$my_htop_platform" = "freebsd"; then
AC_CHECK_LIB([kvm], [kvm_open], [], [missing_libraries="$missing_libraries libkvm"])
fi
+if test "$my_htop_platform" = "openbsd"; then
+ AC_CHECK_LIB([kvm], [kvm_open], [], [missing_libraries="$missing_libraries libkvm"])
+fi
+
AC_ARG_ENABLE(native_affinity, [AC_HELP_STRING([--enable-native-affinity], [enable native sched_setaffinity and sched_getaffinity for affinity support, disables hwloc])], ,enable_native_affinity="yes")
if test "x$enable_native_affinity" = xyes -a "x$cross_compiling" = xno; then
AC_MSG_CHECKING([for usable sched_setaffinity])
@@ -211,6 +218,7 @@ AC_DEFINE_UNQUOTED(COPYRIGHT, "(C) 2004-$year Hisham Muhammad", [Copyright messa
# ----------------------------------------------------------------------
AM_CONDITIONAL([HTOP_LINUX], [test "$my_htop_platform" = linux])
AM_CONDITIONAL([HTOP_FREEBSD], [test "$my_htop_platform" = freebsd])
+AM_CONDITIONAL([HTOP_OPENBSD], [test "$my_htop_platform" = openbsd])
AM_CONDITIONAL([HTOP_DARWIN], [test "$my_htop_platform" = darwin])
AM_CONDITIONAL([HTOP_UNSUPPORTED], [test "$my_htop_platform" = unsupported])
AC_SUBST(my_htop_platform)

© 2014-2024 Faster IT GmbH | imprint | privacy policy