summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHisham Muhammad <hisham@gobolinux.org>2015-11-19 13:26:11 -0200
committerHisham Muhammad <hisham@gobolinux.org>2015-11-19 13:26:11 -0200
commit347141502bd35f81f33cda69cea350fb984e5098 (patch)
tree100b3af6fe5e70d0dd761740d26259a3674ad763 /configure.ac
parent0837fc5b62c298b0232b5b716278a1e162a423bf (diff)
Test for unicode-enabled libncurses
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f865cbf2..1fd6bd61 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,13 +146,15 @@ fi
AC_ARG_ENABLE(unicode, [AC_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes")
if test "x$enable_unicode" = xyes; then
- AC_CHECK_LIB([ncursesw6], [refresh], [
+ AC_CHECK_LIB([ncursesw6], [addnwstr], [
AC_DEFINE(HAVE_LIBNCURSESW, 1, [])
LIBS="-lncursesw6 $LIBS "
], [
- AC_CHECK_LIB([ncursesw], [refresh], [], [
- missing_libraries="$missing_libraries libncursesw"
- AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
+ AC_CHECK_LIB([ncursesw], [addnwstr], [], [
+ AC_CHECK_LIB([ncurses], [addnwstr], [], [
+ missing_libraries="$missing_libraries libncursesw"
+ AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
+ ])
])
])
AC_CHECK_HEADERS([ncursesw/curses.h],[:],

© 2014-2024 Faster IT GmbH | imprint | privacy policy