summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Scott <nathans@redhat.com>2021-06-23 17:44:56 +1000
committerNathan Scott <nathans@redhat.com>2021-07-07 10:59:36 +1000
commitf0ed0fdafb9ecefc9d103ffb8f5d91bf723518f6 (patch)
tree8f82bf54c96a07d8efa5c9a8bd2c50865bd6757a /Makefile.am
parent865b85eb2d31321e9c37334838fa514ac348d61a (diff)
Add a new DynamicMeter class for runtime Meter extension
This commit is based on exploratory work by Sohaib Mohamed. The end goal is two-fold - to support addition of Meters we build via configuration files for both the PCP platform and for scripts ( https://github.com/htop-dev/htop/issues/526 ) Here, we focus on generic code and the PCP support. A new class DynamicMeter is introduced - it uses the special case 'param' field handling that previously was used only by the CPUMeter, such that every runtime-configured Meter is given a unique identifier. Unlike with the CPUMeter this is used internally only. When reading/writing to htoprc instead of CPU(N) - where N is an integer param (CPU number) - we use the string name for each meter. For example, if we have a configuration for a DynamicMeter for some Redis metrics, we might read and write "Dynamic(redis)". This identifier is subsequently matched (back) up to the configuration file so we're able to re-create arbitrary user configurations. The PCP platform configuration file format is fairly simple. We expand configs from several directories, including the users homedir alongside htoprc (below htop/meters/) and also /etc/pcp/htop/meters. The format will be described via a new pcp-htop(5) man page, but its basically ini-style and each Meter has one or more metric expressions associated, as well as specifications for labels, color and so on via a dot separated notation for individual metrics within the Meter. A few initial sample configuration files are provided below ./pcp/meters that give the general idea. The PCP "derived" metric specification - see pmRegisterDerived(3) - is used as the syntax for specifying metrics in PCP DynamicMeters.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 079bcd86..ce50d0f7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,7 @@ myhtopsources = \
DateTimeMeter.c \
DiskIOMeter.c \
DisplayOptionsPanel.c \
+ DynamicMeter.c \
EnvScreen.c \
FunctionBar.c \
Hashtable.c \
@@ -93,6 +94,7 @@ myhtopheaders = \
DateTimeMeter.h \
DiskIOMeter.h \
DisplayOptionsPanel.h \
+ DynamicMeter.h \
EnvScreen.h \
FunctionBar.h \
Hashtable.h \
@@ -357,6 +359,7 @@ endif
# --------------------------
pcp_platform_headers = \
+ pcp/PCPDynamicMeter.h \
pcp/PCPProcess.h \
pcp/PCPProcessList.h \
pcp/Platform.h \
@@ -369,6 +372,7 @@ pcp_platform_headers = \
zfs/ZfsCompressedArcMeter.h
pcp_platform_sources = \
+ pcp/PCPDynamicMeter.c \
pcp/PCPProcess.c \
pcp/PCPProcessList.c \
pcp/Platform.c \

© 2014-2024 Faster IT GmbH | imprint | privacy policy