summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNathan Scott <nathans@redhat.com>2021-02-17 14:43:56 +1100
committerNathan Scott <nathans@redhat.com>2021-06-09 17:09:29 +1000
commitc14a45ba359148fa0abe7ab72ed8ea0c1aa1ce28 (patch)
treee1814f53637daab6e8a781e317a3a5a1915a0144 /Makefile.am
parentd075d49a0ccd3f311bc0f3d2b4c9f542aff1d613 (diff)
Add a platform for Performance Co-Pilot (PCP) metrics
This introduces an initial platform for extracting metrics using the PCP performance metrics API - PMAPI(3). It can be used via the --enable-pcp=yes configure option. So far I've added support for live localhost metrics only, and only using pre-defined metrics already found in htop. If available, all sampling is performed by pmcd(1) - else, we fallback to htop doing the metric sampling itself (all below the PMAPI). When pmcd is used, it may be configured to run children with elevated privileges, so htop does not need to be setuid (authentication with pmcd is available). Additionally, the PMAPI allows us to support archives (for historical analysis and for automated regression tests in htop). We'll need platform-specific command line argument additions, which isn't yet feasible in htop (not difficult to add though). The goal of this first version is minimal impact in terms of modifying the htop codebase, to introduce key ideas in PCP (metric namespace, metadata, APIs and so on) and give us something to discuss, experiment with and build on.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f9b9a7d4..c66aa46c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -328,6 +328,29 @@ myhtopplatheaders = $(solaris_platform_headers)
myhtopplatsources = $(solaris_platform_sources)
endif
+# Performance Co-Pilot (PCP)
+# --------------------------
+
+pcp_platform_headers = \
+ pcp/PCPProcess.h \
+ pcp/PCPProcessList.h \
+ pcp/Platform.h \
+ pcp/ProcessField.h \
+ linux/PressureStallMeter.h \
+ linux/ZramMeter.h \
+ linux/ZramStats.h
+
+if HTOP_PCP
+myhtopplatsources = \
+ pcp/PCPProcess.c \
+ pcp/PCPProcessList.c \
+ pcp/Platform.c \
+ linux/PressureStallMeter.c \
+ linux/ZramMeter.c
+
+myhtopplatheaders = $(pcp_platform_headers)
+endif
+
# Unsupported
# -----------

© 2014-2024 Faster IT GmbH | imprint | privacy policy