summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Lange <DLange@git.local>2021-02-17 15:19:59 +0100
committerDaniel Lange <DLange@git.local>2021-02-17 15:19:59 +0100
commitb1befa328786c1c2a2b0507786c9cc50cf7576e1 (patch)
tree8317b4fc5e96426ab595caedea3e7b6b0b82a059 /Makefile.am
parente0dec39203f30a53403ef9d52f9d2e97efc6703a (diff)
parenta89521ed7f67a8ae5e81a4d01906bfaf17cb6d48 (diff)
Merge branch 'enable-better-debug-on-enable-debug' of fasterit/htop
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 730016aa..0498fc8a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -295,10 +295,10 @@ profile:
$(MAKE) all AM_CPPFLAGS="-pg -O2 -DNDEBUG"
debug:
- $(MAKE) all AM_CPPFLAGS="-ggdb -DDEBUG"
+ $(MAKE) all AM_CPPFLAGS="-ggdb3 -Og" CFLAGS="$(patsubst -O%,,$(CFLAGS))"
coverage:
- $(MAKE) all AM_CPPFLAGS="-fprofile-arcs -ftest-coverage -DDEBUG" AM_LDFLAGS="-lgcov"
+ $(MAKE) all AM_CPPFLAGS="-fprofile-arcs -ftest-coverage" AM_LDFLAGS="-lgcov"
cppcheck:
cppcheck -q -v . --enable=all -DHAVE_OPENVZ

© 2014-2024 Faster IT GmbH | imprint | privacy policy