summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorfraggerfox <santhosh.raju@gmail.com>2021-03-15 13:14:39 +0530
committerBenBE <BenBE@geshi.org>2021-06-26 12:18:37 +0200
commit4b49de44a8659674c6e92ba70e0c1930b2b9315b (patch)
treed831fd16f5a13843766d9ae18a0060ff1b3d5b39 /Makefile.am
parent30dc4a28125e7199a51abde86af7b73027fa0bd2 (diff)
Add NetBSD platform support without procfs dependency
- TODO, clean up the code base and update comments in code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ca687d4c..a533245f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -236,6 +236,30 @@ myhtopplatheaders = $(dragonflybsd_platform_headers)
myhtopplatsources = $(dragonflybsd_platform_sources)
endif
+# NetBSD
+# -------
+
+netbsd_platform_headers = \
+ netbsd/Platform.h \
+ netbsd/ProcessField.h \
+ netbsd/NetBSDProcessList.h \
+ netbsd/NetBSDProcess.h \
+ generic/hostname.h \
+ generic/uname.h
+
+netbsd_platform_sources = \
+ netbsd/Platform.c \
+ netbsd/NetBSDProcessList.c \
+ netbsd/NetBSDProcess.c \
+ generic/hostname.c \
+ generic/uname.c
+
+if HTOP_NETBSD
+AM_LDFLAGS += -lkvm
+myhtopplatheaders = $(netbsd_platform_headers)
+myhtopplatsources = $(netbsd_platform_sources)
+endif
+
# OpenBSD
# -------

© 2014-2024 Faster IT GmbH | imprint | privacy policy