summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenny Baumann <BenBE@geshi.org>2021-08-02 00:43:10 +0200
committerBenny Baumann <BenBE@geshi.org>2021-08-02 00:43:10 +0200
commit44e01dd32b417ff0118cfa6183f31032966a93c1 (patch)
tree54f7dd084469ca6497fd89013e4ea0b1cc8c881f /Makefile.am
parent03705a20aaeaa37bf414e088e051689f65a716e5 (diff)
Makefile.am fix that actually does a proper substitution
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f481b8d3..1e027c6a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -423,7 +423,7 @@ profile:
$(MAKE) all AM_CPPFLAGS="-pg -O2 -DNDEBUG"
debug:
- $(MAKE) all AM_CPPFLAGS="-ggdb3 -Og" CFLAGS="`patsubst -O%,,$(CFLAGS)`"
+ $(MAKE) all AM_CPPFLAGS="-ggdb3 -Og" CFLAGS="`printf ' %s ' "$(CFLAGS)"|sed -E 's#[[:space:]]-O[^[:space:]]+[[:space:]]# #g'` -ggdb3 -Og"
coverage:
$(MAKE) all AM_CPPFLAGS="-fprofile-arcs -ftest-coverage" AM_LDFLAGS="-lgcov"

© 2014-2024 Faster IT GmbH | imprint | privacy policy