summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenny Baumann <BenBE@geshi.org>2020-11-21 22:31:10 +0100
committerBenny Baumann <BenBE@geshi.org>2020-11-21 22:31:10 +0100
commitd2c64c16e6712fe022d9013c5b602754a372338d (patch)
tree5dd029a0e0ab89ceee342b68335872594ffbbdd6 /Makefile.am
parent0f4e3ebc955347e80f6d098422e79f6f6202eeb0 (diff)
Fix build for custom make targets
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index aa044e82..07b7b168 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -271,13 +271,13 @@ target:
echo $(htop_SOURCES)
profile:
- $(MAKE) all CFLAGS="-pg" AM_CPPFLAGS="-pg -O2 -DNDEBUG"
+ $(MAKE) all AM_CPPFLAGS="-pg -O2 -DNDEBUG"
debug:
- $(MAKE) all CFLAGS="" AM_CPPFLAGS="-ggdb -DDEBUG"
+ $(MAKE) all AM_CPPFLAGS="-ggdb -DDEBUG"
coverage:
- $(MAKE) all CFLAGS="" AM_CPPFLAGS="-fprofile-arcs -ftest-coverage -DDEBUG" LDFLAGS="-lgcov"
+ $(MAKE) all AM_CPPFLAGS="-fprofile-arcs -ftest-coverage -DDEBUG" AM_LDFLAGS="-lgcov"
cppcheck:
cppcheck -q -v . --enable=all -DHAVE_CGROUP -DHAVE_OPENVZ -DHAVE_TASKSTATS

© 2014-2024 Faster IT GmbH | imprint | privacy policy