summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHisham Muhammad <hisham@gobolinux.org>2015-03-15 22:53:10 -0300
committerHisham Muhammad <hisham@gobolinux.org>2015-03-15 22:53:10 -0300
commitd2acffa59abba396b710f71436823c54bfcf2f7e (patch)
tree495599681c0cfd4288ade3f4b9482434a1988a6b /Makefile.am
parentc29e53c5d5aa9b9a5e13ea5ee74bb0fd13fc7f93 (diff)
parent50000d808e23a80b8e3ec26b46062c419edff6d4 (diff)
Merge branch 'wip' of https://github.com/hishamhm/htop into freebsd
Conflicts: htop.c unsupported/Platform.h
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 7f199328..bdf7b05a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,11 +12,11 @@ applications_DATA = htop.desktop
pixmapdir = $(datadir)/pixmaps
pixmap_DATA = htop.png
-htop_CFLAGS = -pedantic -Wall -Wextra -std=c99 -rdynamic -D_XOPEN_SOURCE_EXTENDED -DSYSCONFDIR=\"$(sysconfdir)\" -I"$(my_htop_platform)"
+htop_CFLAGS = -pedantic -Wall $(wextra_flag) -std=c99 -rdynamic -D_XOPEN_SOURCE_EXTENDED -DSYSCONFDIR=\"$(sysconfdir)\" -I"$(my_htop_platform)"
AM_CPPFLAGS = -DNDEBUG
myhtopsources = AvailableMetersPanel.c CategoriesPanel.c CheckItem.c \
-ClockMeter.c ColorsPanel.c ColumnsPanel.c CPUMeter.c CRT.c \
+ClockMeter.c ColorsPanel.c ColumnsPanel.c CPUMeter.c CRT.c MainPanel.c \
DisplayOptionsPanel.c FunctionBar.c Hashtable.c Header.c htop.c ListItem.c \
LoadAverageMeter.c MemoryMeter.c Meter.c MetersPanel.c Object.c Panel.c \
BatteryMeter.c Process.c ProcessList.c RichString.c ScreenManager.c Settings.c \
@@ -26,7 +26,7 @@ HostnameMeter.c OpenFilesScreen.c Affinity.c IncSet.c Action.c
myhtopheaders = AvailableColumnsPanel.h AvailableMetersPanel.h \
CategoriesPanel.h CheckItem.h ClockMeter.h ColorsPanel.h ColumnsPanel.h \
-CPUMeter.h CRT.h DisplayOptionsPanel.h FunctionBar.h \
+CPUMeter.h CRT.h MainPanel.h DisplayOptionsPanel.h FunctionBar.h \
Hashtable.h Header.h htop.h ListItem.h LoadAverageMeter.h MemoryMeter.h \
BatteryMeter.h Meter.h MetersPanel.h Object.h Panel.h ProcessList.h RichString.h \
ScreenManager.h Settings.h SignalsPanel.h String.h SwapMeter.h TasksMeter.h \
@@ -50,11 +50,13 @@ freebsd/FreeBSDCRT.h
endif
if HTOP_UNSUPPORTED
-myhtopplatsources = unsupported/Platform.c unsupported/UnsupportedProcessList.c \
-unsupported/UnsupportedCRT.c
+myhtopplatsources = unsupported/Platform.c \
+unsupported/UnsupportedProcess.c unsupported/UnsupportedProcessList.c \
+unsupported/UnsupportedCRT.c unsupported/Battery.c
-myhtopplatheaders = unsupported/Platform.h unsupported/UnsupportedProcessList.h \
-unsupported/UnsupportedCRT.h
+myhtopplatheaders = unsupported/Platform.h \
+unsupported/UnsupportedProcess.h unsupported/UnsupportedProcessList.h \
+unsupported/UnsupportedCRT.h unsupported/Battery.h
endif
SUFFIXES = .h

© 2014-2024 Faster IT GmbH | imprint | privacy policy