summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorZev Weiss <zev@bewilderbeest.net>2019-12-21 01:09:25 -0800
committerZev Weiss <zev@bewilderbeest.net>2020-09-03 11:58:58 -0500
commita1a027b9bd833db5384d7dc65046194018eb8bfa (patch)
treec8e906c53b485435ceb79b30a3b5faa28554f0ca /Makefile.am
parent7734dfe55d7c005063f2682e5611fc11e9143fd9 (diff)
Axe automated header generation.
Reasoning: - implementation was unsound -- broke down when I added a fairly basic macro definition expanding to a struct initializer in a *.c file. - made it way too easy (e.g. via otherwise totally innocuous git commands) to end up with timestamps such that it always ran MakeHeader.py but never used its output, leading to overbuild noise when running what should be a null 'make'. - but mostly: it's just an awkward way of dealing with C code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 2 insertions, 31 deletions
diff --git a/Makefile.am b/Makefile.am
index d455b4d4..5bf172b0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,7 @@ AUTOMAKE_OPTIONS = subdir-objects
bin_PROGRAMS = htop
dist_man_MANS = htop.1
-EXTRA_DIST = $(dist_man_MANS) htop.desktop htop.png scripts/MakeHeader.py \
+EXTRA_DIST = $(dist_man_MANS) htop.desktop htop.png \
install-sh autogen.sh missing
applicationsdir = $(datadir)/applications
applications_DATA = htop.desktop
@@ -36,8 +36,6 @@ TasksMeter.h UptimeMeter.h TraceScreen.h UsersTable.h Vector.h Process.h \
AffinityPanel.h HostnameMeter.h OpenFilesScreen.h Affinity.h IncSet.h Action.h \
EnvScreen.h InfoScreen.h XAlloc.h
-all_platform_headers =
-
# Linux
# -----
@@ -54,11 +52,9 @@ linux_platform_headers = \
zfs/ZfsCompressedArcMeter.h \
zfs/ZfsArcStats.h
-all_platform_headers += $(linux_platform_headers)
-
if HTOP_LINUX
AM_LDFLAGS += -rdynamic
-myhtopplatsources = linux/Platform.c linux/IOPriorityPanel.c linux/IOPriority.c \
+myhtopplatsources = linux/Platform.c linux/IOPriorityPanel.c \
linux/LinuxProcess.c linux/LinuxProcessList.c linux/LinuxCRT.c linux/Battery.c \
linux/PressureStallMeter.c \
zfs/ZfsArcMeter.c zfs/ZfsCompressedArcMeter.c zfs/ZfsArcStats.c
@@ -80,8 +76,6 @@ freebsd_platform_headers = \
zfs/ZfsArcStats.h \
zfs/openzfs_sysctl.h
-all_platform_headers += $(freebsd_platform_headers)
-
if HTOP_FREEBSD
myhtopplatsources = freebsd/Platform.c freebsd/FreeBSDProcessList.c \
freebsd/FreeBSDProcess.c freebsd/FreeBSDCRT.c freebsd/Battery.c \
@@ -100,8 +94,6 @@ dragonflybsd_platform_headers = \
dragonflybsd/DragonFlyBSDCRT.h \
dragonflybsd/Battery.h
-all_platform_headers += $(dragonflybsd_platform_headers)
-
if HTOP_DRAGONFLYBSD
AM_LDFLAGS += -lkvm -lkinfo -lexecinfo
myhtopplatsources = dragonflybsd/Platform.c dragonflybsd/DragonFlyBSDProcessList.c \
@@ -120,8 +112,6 @@ openbsd_platform_headers = \
openbsd/OpenBSDCRT.h \
openbsd/Battery.h
-all_platform_headers += $(openbsd_platform_headers)
-
if HTOP_OPENBSD
myhtopplatsources = openbsd/Platform.c openbsd/OpenBSDProcessList.c \
openbsd/OpenBSDProcess.c openbsd/OpenBSDCRT.c openbsd/Battery.c
@@ -143,8 +133,6 @@ darwin_platform_headers = \
zfs/ZfsArcStats.h \
zfs/openzfs_sysctl.h
-all_platform_headers += $(darwin_platform_headers)
-
if HTOP_DARWIN
AM_LDFLAGS += -framework IOKit -framework CoreFoundation
myhtopplatsources = darwin/Platform.c darwin/DarwinProcess.c \
@@ -167,8 +155,6 @@ solaris_platform_headers = \
zfs/ZfsCompressedArcMeter.h \
zfs/ZfsArcStats.h
-all_platform_headers += $(solaris_platform_headers)
-
if HTOP_SOLARIS
myhtopplatsources = solaris/Platform.c \
solaris/SolarisProcess.c solaris/SolarisProcessList.c \
@@ -188,8 +174,6 @@ unsupported_platform_headers = \
unsupported/UnsupportedCRT.h \
unsupported/Battery.h
-all_platform_headers += $(unsupported_platform_headers)
-
if HTOP_UNSUPPORTED
myhtopplatsources = unsupported/Platform.c \
unsupported/UnsupportedProcess.c unsupported/UnsupportedProcessList.c \
@@ -200,19 +184,9 @@ endif
# ----
-SUFFIXES = .h
-
-BUILT_SOURCES = $(myhtopheaders) $(myhtopplatheaders)
htop_SOURCES = $(myhtopheaders) $(myhtopplatheaders) $(myhtopsources) $(myhtopplatsources)
nodist_htop_SOURCES = config.h
-.PHONY: htop-headers clean-htop-headers
-
-htop-headers: $(myhtopheaders) $(all_platform_headers)
-
-clean-htop-headers:
- -rm -f $(myhtopheaders) $(all_platform_headers)
-
target:
echo $(htop_SOURCES)
@@ -225,9 +199,6 @@ debug:
coverage:
$(MAKE) all CFLAGS="" AM_CPPFLAGS="-fprofile-arcs -ftest-coverage -DDEBUG" LDFLAGS="-lgcov"
-.c.h:
- ./scripts/MakeHeader.py $<
-
cppcheck:
cppcheck -q -v . --enable=all -DHAVE_CGROUP -DHAVE_OPENVZ -DHAVE_TASKSTATS

© 2014-2024 Faster IT GmbH | imprint | privacy policy