summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Göttsche <cgzones@googlemail.com>2020-12-15 19:44:48 +0100
committercgzones <cgzones@googlemail.com>2020-12-19 21:13:32 +0100
commit89473cc9ae950bbb5e291d1f186d372f66f66394 (patch)
treed1e21dbd0df28c00c467695711c8dde884e746a1 /Makefile.am
parentd872e363081a892d65dede6a90721d3a2e8b0ee6 (diff)
Rework enum ProcessField
Use only one enum instead of a global and a platform specific one. Drop Platform_numberOfFields global variable. Set known size of Process_fields array
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 09790fa4..80527829 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -133,6 +133,7 @@ linux_platform_headers = \
linux/LinuxProcessList.h \
linux/Platform.h \
linux/PressureStallMeter.h \
+ linux/ProcessField.h \
linux/SELinuxMeter.h \
linux/SystemdMeter.h \
linux/ZramMeter.h \
@@ -164,9 +165,10 @@ endif
# -------
freebsd_platform_headers = \
- freebsd/Platform.h \
freebsd/FreeBSDProcessList.h \
freebsd/FreeBSDProcess.h \
+ freebsd/Platform.h \
+ freebsd/ProcessField.h \
zfs/ZfsArcMeter.h \
zfs/ZfsCompressedArcMeter.h \
zfs/ZfsArcStats.h \
@@ -184,9 +186,10 @@ endif
# ------------
dragonflybsd_platform_headers = \
- dragonflybsd/Platform.h \
dragonflybsd/DragonFlyBSDProcessList.h \
- dragonflybsd/DragonFlyBSDProcess.h
+ dragonflybsd/DragonFlyBSDProcess.h \
+ dragonflybsd/Platform.h \
+ dragonflybsd/ProcessField.h
if HTOP_DRAGONFLYBSD
AM_LDFLAGS += -lkvm -lkinfo
@@ -200,9 +203,10 @@ endif
# -------
openbsd_platform_headers = \
- openbsd/Platform.h \
openbsd/OpenBSDProcessList.h \
- openbsd/OpenBSDProcess.h
+ openbsd/OpenBSDProcess.h \
+ openbsd/Platform.h \
+ openbsd/ProcessField.h
if HTOP_OPENBSD
myhtopplatsources = openbsd/Platform.c openbsd/OpenBSDProcessList.c \
@@ -215,9 +219,10 @@ endif
# ------
darwin_platform_headers = \
- darwin/Platform.h \
darwin/DarwinProcess.h \
darwin/DarwinProcessList.h \
+ darwin/Platform.h \
+ darwin/ProcessField.h \
zfs/ZfsArcMeter.h \
zfs/ZfsCompressedArcMeter.h \
zfs/ZfsArcStats.h \
@@ -237,6 +242,7 @@ endif
solaris_platform_headers = \
solaris/Platform.h \
+ solaris/ProcessField.h \
solaris/SolarisProcess.h \
solaris/SolarisProcessList.h \
zfs/ZfsArcMeter.h \
@@ -256,6 +262,7 @@ endif
unsupported_platform_headers = \
unsupported/Platform.h \
+ unsupported/ProcessField.h \
unsupported/UnsupportedProcess.h \
unsupported/UnsupportedProcessList.h

© 2014-2024 Faster IT GmbH | imprint | privacy policy