summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorgmbroome <thrirhrafnir@gmail.com>2018-03-02 16:20:46 -0500
committerHisham Muhammad <hisham@gobolinux.org>2018-03-02 18:20:46 -0300
commit697f5bb9c14a89b2e04519c956fc7e455c9b1cc0 (patch)
tree12cb2f0f92308da316e623d7b1911308454ea02a /Makefile.am
parentd4ea7cd65ccf8551cabb0706167b2c15aad7866d (diff)
Import Solaris support (#741)
This commit adds support for Solaris, squashed from PR #741: Summary of additions: * Initial setup of Solaris platform directory * Add Solaris platform into autoconf template * Uptime and load averages * Add dependency on libkstat * Basic process listing * Zone name display * CPU detection * Per-process memory and CPU usage parsed correctly * Uses sysconf to discover number of CPUs, instead of more complex libkstat code * Simple memory display working * Reduce repetitive calls to the PAGE_SIZE macro when reading memory info * Add Project, Contract, Task, and Pool into process properties * Use system major()/minor() implementations and remove extraneous definition of mkdev() * Get the STARTTIME column working properly, using the Linux implementation as a guide
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e033c35d..a3a5b6b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,6 +79,16 @@ myhtopplatheaders = darwin/Platform.h darwin/DarwinProcess.h \
darwin/DarwinProcessList.h darwin/DarwinCRT.h darwin/Battery.h
endif
+if HTOP_SOLARIS
+myhtopplatsources = solaris/Platform.c \
+solaris/SolarisProcess.c solaris/SolarisProcessList.c \
+solaris/SolarisCRT.c solaris/Battery.c
+
+myhtopplatheaders = solaris/Platform.h \
+solaris/SolarisProcess.h solaris/SolarisProcessList.h \
+solaris/SolarisCRT.h solaris/Battery.h
+endif
+
if HTOP_UNSUPPORTED
myhtopplatsources = unsupported/Platform.c \
unsupported/UnsupportedProcess.c unsupported/UnsupportedProcessList.c \

© 2014-2024 Faster IT GmbH | imprint | privacy policy