summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Hunt <dhunt@iolanthe.attlocal.net>2015-07-12 13:47:43 -0500
committerHisham Muhammad <hisham@gobolinux.org>2015-08-19 13:47:26 -0300
commit70e7c8db592408f45b958238d4bbf0048886f6fc (patch)
tree0ee699faad92f38d29d10b5c9faced3436f0c647 /Makefile.am
parentfeb7a01fd32d4a63b9cfb178c67cc95c05c9dc00 (diff)
Added darwin with working battery meter
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 46377fc3..8fa38197 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,6 +13,7 @@ pixmapdir = $(datadir)/pixmaps
pixmap_DATA = htop.png
htop_CFLAGS = -pedantic -Wall $(wextra_flag) -std=c99 -D_XOPEN_SOURCE_EXTENDED -DSYSCONFDIR=\"$(sysconfdir)\" -I"$(top_srcdir)/$(my_htop_platform)"
+htop_LDFLAGS =
AM_CPPFLAGS = -DNDEBUG
myhtopsources = AvailableMetersPanel.c CategoriesPanel.c CheckItem.c \
@@ -50,6 +51,15 @@ myhtopplatheaders = freebsd/Platform.h freebsd/FreeBSDProcessList.h \
freebsd/FreeBSDProcess.h freebsd/FreeBSDCRT.h freebsd/Battery.h
endif
+if HTOP_DARWIN
+htop_LDFLAGS += -framework IOKit -framework CoreFoundation
+myhtopplatsources = darwin/Platform.c darwin/DarwinProcess.c \
+darwin/DarwinProcessList.c darwin/DarwinCRT.c darwin/Battery.c
+
+myhtopplatheaders = darwin/Platform.h darwin/DarwinProcess.h \
+darwin/DarwinProcessList.h darwin/DarwinCRT.h darwin/Battery.h
+endif
+
if HTOP_UNSUPPORTED
myhtopplatsources = unsupported/Platform.c \
unsupported/UnsupportedProcess.c unsupported/UnsupportedProcessList.c \

© 2014-2024 Faster IT GmbH | imprint | privacy policy