summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHisham Muhammad <hisham@gobolinux.org>2015-03-25 17:14:40 -0300
committerHisham Muhammad <hisham@gobolinux.org>2015-03-25 17:14:40 -0300
commit80ef119fe77ccea1c784fb113bc28b5547e321e4 (patch)
tree2bd184acfd4f95cefda4adc8f4a6798194545f44 /Makefile.am
parent70abaadbaf9acfc9daff12728ea7a9e1092ff3f0 (diff)
Add coverage testing rules
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3b3ba432..d47f755a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -74,9 +74,18 @@ profile:
debug:
$(MAKE) all CFLAGS="" AM_CPPFLAGS="-ggdb -DDEBUG"
+coverage:
+ $(MAKE) all CFLAGS="" AM_CPPFLAGS="-fprofile-arcs -ftest-coverage -DDEBUG" AM_LDFLAGS="-lgcov"
+
.c.h:
@srcdir@/scripts/MakeHeader.py $<
cppcheck:
cppcheck -q -v . --enable=all -DHAVE_CGROUP -DHAVE_OPENVZ -DHAVE_TASKSTATS
+.PHONY: lcov
+
+lcov:
+ mkdir -p lcov
+ lcov --capture --directory . --output-file coverage.info
+ genhtml coverage.info --output-directory lcov

© 2014-2024 Faster IT GmbH | imprint | privacy policy