summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHisham Muhammad <hisham@gobolinux.org>2008-03-05 09:46:47 +0000
committerHisham Muhammad <hisham@gobolinux.org>2008-03-05 09:46:47 +0000
commit4df76d127b9cf830a15244da75976efb43752c6b (patch)
tree79074341a3cd73003186d0290ecad71cb9bed623 /Makefile.am
parent5ed2b85c847995da3f4dc01c4d2790358adeb03d (diff)
Embed PLPA (Portable Linux Processor Affinity) in order to support
conflicting affinity API of different Linux kernel versions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d1ef6e38..26b18aa7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,6 @@
+SUBDIRS = plpa-1.1
+
bin_PROGRAMS = htop
dist_man_MANS = htop.1
EXTRA_DIST = $(dist_man_MANS) htop.desktop htop.png scripts/MakeHeader.py \
@@ -8,7 +10,7 @@ applications_DATA = htop.desktop
pixmapdir = $(datadir)/pixmaps
pixmap_DATA = htop.png
-AM_CFLAGS = -pedantic -Wall -std=c99
+htop_CFLAGS = -pedantic -Wall -std=c99
AM_CPPFLAGS = -DSYSCONFDIR=\"$(sysconfdir)\"
myhtopsources = AvailableMetersPanel.c CategoriesPanel.c CheckItem.c \
@@ -32,6 +34,7 @@ SUFFIXES = .h
BUILT_SOURCES = $(myhtopheaders)
htop_SOURCES = $(myhtopheaders) $(myhtopsources) config.h debug.h
+htop_LDADD = $(top_builddir)/plpa-1.1/src/libplpa_included.la
profile:
$(MAKE) all CFLAGS="-pg -O2"

© 2014-2024 Faster IT GmbH | imprint | privacy policy