summaryrefslogtreecommitdiffstats
path: root/lib
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <pochu@debian.org>2019-12-02 17:22:18 +0100
committerEmilio Pozuelo Monfort <pochu@debian.org>2020-02-26 12:31:30 +0100
commit0d22e6b8aed18a81f2249376f6d78e2de8d25348 (patch)
treee3ae0346475b0418ae94ac5fe47c477a5189bbc0 /lib
parentad210ce2b8543a88371b3c2f0d1a668c002c195e (diff)
Don't hardcode architecture list in the Makefile
Move it to config.json instead and grab it from there.
Diffstat (limited to 'lib')
-rw-r--r--lib/debian-releases.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/debian-releases.mk b/lib/debian-releases.mk
index c868d6edfd..d09ac33be0 100644
--- a/lib/debian-releases.mk
+++ b/lib/debian-releases.mk
@@ -1,6 +1,10 @@
# This file defines the variables describing all Debian repositories
# that need to be fetched in the "update-packages" process
+define get_config =
+$(shell jq -r $(1) 'data/config.json')
+endef
+
# backports suites only have Sources.xz and respective Packages.xz
# available.
# Cf. as well https://bugs.debian.org/664866
@@ -12,7 +16,7 @@ MAIN_RELEASES := $(SECURITY_RELEASES) sid
define add_main_release =
$(1)_MIRROR = $$(MIRROR)
$(1)_DIST = $(1)
-$(1)_ARCHS ?= amd64 arm64 armel armhf i386 mips64el mipsel ppc64el s390x
+$(1)_ARCHS = $(call get_config, '.distributions.$(1).architectures[]')
$(1)_RELEASE = $(1)
$(1)_SUBRELEASE =
RELEASES += $(1)

© 2014-2024 Faster IT GmbH | imprint | privacy policy