summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <pochu@debian.org>2019-12-02 17:17:19 +0100
committerEmilio Pozuelo Monfort <pochu@debian.org>2020-02-26 12:31:30 +0100
commitad210ce2b8543a88371b3c2f0d1a668c002c195e (patch)
tree4d922ca01e03298c038dbd684e921537dcf10d81 /Makefile
parent57efb5f3ee70dfce122595f14f367ac136ccd8a3 (diff)
Makefile: remove update-$(alias) targets
They are aliases for the real update-$(dist) targets, and are unused as we mostly use update-packages target, which directly calls the update-$(dist) ones.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 0 insertions, 18 deletions
diff --git a/Makefile b/Makefile
index 545a293228..cf6cc968c5 100644
--- a/Makefile
+++ b/Makefile
@@ -78,30 +78,12 @@ endef
$(foreach release,$(RELEASES),$(eval $(call add_update_rule,$(release))))
# Define some common aliases
-.PHONY: update-unstable update-testing update-stable update-oldstable update-oldoldstable
-.PHONY: update-testing-security update-stable-security update-oldstable-security update-oldoldstable-security
.PHONY: update-main update-security update-backports
-update-unstable: update-sid
-update-testing: update-$(TESTING)
-update-testing-security: update-$(TESTING)_security
-update-stable: update-$(STABLE)
-update-stable-security: update-$(STABLE)_security
-update-oldstable: update-$(OLDSTABLE)
-update-oldstable-security: update-$(OLDSTABLE)_security
-ifeq ($(OLDOLDSTABLE),)
-update-oldoldstable:
-update-oldoldstable-security:
-else
-update-oldoldstable: update-$(OLDOLDSTABLE)
-update-oldoldstable-security: update-$(OLDOLDSTABLE)_security
-endif
update-main: $(foreach release,$(MAIN_RELEASES),update-$(release))
update-security: $(foreach release,$(SECURITY_RELEASES),update-$(release)_security)
update-backports: $(foreach release,$(BACKPORT_RELEASES),update-$(release)_backports)
supported-update-targets:
- @echo -n "unstable testing stable oldstable oldoldstable "
- @echo -n "testing-security stable-security oldstable-security oldoldstable-security "
@echo -n "main security backports "
@echo -n "$(RELEASES) "
@echo -n "packages lists nvd"

© 2014-2024 Faster IT GmbH | imprint | privacy policy