summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRaphaël Hertzog <hertzog@debian.org>2018-05-31 16:24:16 +0200
committerRaphaël Hertzog <hertzog@debian.org>2018-05-31 17:46:38 +0200
commit90b247abc4a416f160dc88400d09b0af0a873226 (patch)
tree87cbfe0ca5253b32a39bccbbcbbeb51d5a0471ed /Makefile
parent5a9873fdfca52957c5ca43390958bf1d114dfa14 (diff)
Add some common update-* aliases for convenience
And for the cron jobs running on security-tracker.debian.org.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index b437701676..c004efd998 100644
--- a/Makefile
+++ b/Makefile
@@ -97,6 +97,29 @@ update-$(1):
endef
$(foreach release,$(RELEASES),$(eval $(call add_update_rule,$(release))))
+# Define some common aliases
+.PHONY: update-unstable update-testing update-stable update-oldstable update-oldoldstable
+.PHONY: update-testing-security update-stable-security update-oldstable-security update-oldoldstable-security
+.PHONY: update-main update-security update-backports
+update-unstable: update-sid
+update-testing: update-$(TESTING)
+update-testing-security: update-$(TESTING)_security
+update-stable: update-$(STABLE)
+update-stable-security: update-$(STABLE)_security
+update-oldstable: update-$(OLDSTABLE)
+update-oldstable-security: update-$(OLDSTABLE)_security
+ifeq ($(OLDOLDSTABLE),)
+update-oldoldstable:
+update-oldoldstable-security:
+else
+update-oldoldstable: update-$(OLDOLDSTABLE)
+update-oldoldstable-security: update-$(OLDOLDSTABLE)_security
+endif
+update-main: $(foreach release,$(MAIN_RELEASES),update-$(release))
+update-security: $(foreach release,$(SECURITY_RELEASES),update-$(release)_security)
+update-backports: $(foreach release,$(BACKPORT_RELEASES),update-$(release)_backports)
+
+# Other custom update rules
update-lists:
git fetch -q origin && git checkout -f origin/master -- data

© 2014-2024 Faster IT GmbH | imprint | privacy policy